aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-09-02 23:03:31 +0800
committerbapt <bapt@FreeBSD.org>2014-09-02 23:03:31 +0800
commit48152c67e9bb77d931eb40a2fda0d4484514a38b (patch)
treebf3d54826eff81c33eb09768629792fdb41eaaf4 /Mk
parent2b065e9185414ce68bd542097ec63fe22bd17ae2 (diff)
downloadfreebsd-ports-gnome-48152c67e9bb77d931eb40a2fda0d4484514a38b.tar.gz
freebsd-ports-gnome-48152c67e9bb77d931eb40a2fda0d4484514a38b.tar.zst
freebsd-ports-gnome-48152c67e9bb77d931eb40a2fda0d4484514a38b.zip
Add home directory creation to pre-install script for USERS/GROUPS
Use @dirrmtry instead of @exec rmdir
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index b9c8e1e050fe..adc6424ce243 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3980,7 +3980,7 @@ create-users-groups:
echo \"Creating user '$$login' with uid '$$uid'.\" \n \
${PW} useradd $$login -u $$uid -g $$gid $$class -c \"$$gecos\" -d $$homedir -s $$shell \n \
else \necho \"Using existing user '$$login'.\" \nfi" >> ${_UG_OUTPUT}; \
- case $$homedir in /|/nonexistent|/var/empty) ;; *) ${ECHO_CMD} "@exec ${INSTALL} -d -g $$gid -o $$uid $$homedir" >> ${TMPPLIST};; esac; \
+ case $$homedir in /|/nonexistent|/var/empty) ;; *) ${ECHO_CMD} "${INSTALL} -d -g $$gid -o $$uid $$homedir" >> ${_UG_OUTPUT};; esac; \
done
.endfor
.if defined(GROUPS)
@@ -5461,7 +5461,7 @@ add-plist-info:
.if (${PREFIX} != ${LOCALBASE} && ${PREFIX} != ${LINUXBASE} && \
${PREFIX} != "/usr" && !defined(NO_PREFIX_RMDIR))
add-plist-post:
- @${ECHO_CMD} "@unexec rmdir %D 2> /dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrmtry %D" >> ${TMPPLIST}
.endif
.endif