aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-04-23 23:32:29 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2020-04-23 23:32:29 +0800
commit5abe8902a53b7bfd7ab482ec3f59229cdc2e812d (patch)
treedaa44b3bcefdd28f130988ddbc1a68139417194d /Mk
parentc108a6700f69ec335f794e2b36e9077f81facda9 (diff)
downloadfreebsd-ports-gnome-5abe8902a53b7bfd7ab482ec3f59229cdc2e812d.tar.gz
freebsd-ports-gnome-5abe8902a53b7bfd7ab482ec3f59229cdc2e812d.tar.zst
freebsd-ports-gnome-5abe8902a53b7bfd7ab482ec3f59229cdc2e812d.zip
lang/rust: Update to 1.43.0
- Add workaround to fix build when CC/CXX have "clang" in them [1] - Respect AR to fix build with external toolchains [2] - Force rebuild all consumers to catch regressions early Changes: https://blog.rust-lang.org/2020/04/23/Rust-1.43.0.html PR: 238556 [1], 245583 [2] Reported by: Matthias Apitz <guru@unixarea.de> [1], Greg V <greg@unrelenting.technology> [2] Tested by: mikael, pkubaj, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D24521
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 88d95ff466cf..d471383fae95 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -45,7 +45,7 @@ DISTFILES+= ${CARGO_DIST_SUBDIR}/${_crate}.tar.gz:cargo_${_crate:C/[^a-zA-Z0-9_]
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.42.0:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.43.0:lang/${RUST_DEFAULT}
.endif
# Location of cargo binary (default to lang/rust's Cargo binary)