aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /Mk
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
-rw-r--r--Mk/bsd.xorg.mk42
2 files changed, 36 insertions, 16 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 779908723edb..ff47322e72c4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1903,8 +1903,14 @@ X_FONTS_TYPE1_PORT= ${PORTSDIR}/x11-fonts/xorg-fonts-type1
X_FONTS_ALIAS_PORT= ${PORTSDIR}/x11-fonts/font-alias
.if defined(USE_IMAKE)
+.if (${OSVERSION} >= 900506 && ${OSVERSION} < 1000000) || \
+ ${OSVERSION} >= 1000010
+CONFIGURE_ENV+= IMAKECPP="gcpp"
+MAKE_ENV+= IMAKECPP="gcpp"
+.else
CONFIGURE_ENV+= IMAKECPP="${CPP}"
MAKE_ENV+= IMAKECPP="${CPP}"
+.endif
MAKE_FLAGS?= CC="${CC}" CXX="${CXX}"
BUILD_DEPENDS+= imake:${X_IMAKE_PORT}
.endif
@@ -1924,8 +1930,10 @@ MAKE_ENV+= DISPLAY="localhost:1001"
PKG_IGNORE_DEPENDS?= 'this_port_does_not_exist'
_GL_gl_LIB_DEPENDS= GL.1:${PORTSDIR}/graphics/libGL
+_GL_gl_USE_XORG= glproto dri2proto
_GL_glew_LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew
_GL_glu_LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU
+_GL_glu_USE_XORG= glproto dri2proto
_GL_glw_LIB_DEPENDS= GLw.1:${PORTSDIR}/graphics/libGLw
_GL_glut_LIB_DEPENDS= glut.12:${PORTSDIR}/graphics/freeglut
_GL_linux_RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
@@ -1939,6 +1947,8 @@ USE_GL= glu
!defined(_GL_${_component}_RUN_DEPENDS)
IGNORE= uses unknown GL component
. else
+USE_XORG+= ${_GL_${_component}_USE_XORG}
+BUILD_DEPENDS+= ${_GL_${_component}_BUILD_DEPENDS}
LIB_DEPENDS+= ${_GL_${_component}_LIB_DEPENDS}
RUN_DEPENDS+= ${_GL_${_component}_RUN_DEPENDS}
. endif
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index de2736fc5442..951f092a2df1 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -17,14 +17,14 @@ Xorg_Pre_Include= bsd.xorg.mk
# Some notes:
#
-# app - requires pkgconfig, don't install shared libraries (I guess)
-# data - nothing I could factorize
+# app - Installs applications, no shared libraries.
+# data - Installs only data.
# doc - no particular notes
-# driver - input depends on inputproto/renderproto at least
+# driver - input depends on inputproto/randrproto at least
# video depends on randrproto/renderproto at least
# font - don't install .pc file
-# lib - various dependencies, install .pc file
-# proto - install .pc file, no dependencies, needed only at build time for most of them
+# lib - various dependencies, install .pc file, needs pathfix
+# proto - install .pc file, needs pathfix, most only needed at build time.
# xserver - there's only one atm, I guess everything can fit into the port itself
.if defined(XORG_CAT)
@@ -38,8 +38,17 @@ DIST_SUBDIR= xorg/${XORG_CAT}
MASTER_SITES?= ${MASTER_SITE_XORG}
MASTER_SITE_SUBDIR?= individual/${XORG_CAT}
+# All xorg ports needs pkgconfig to build, but some ports look for pkgconfig and
+# then continues the build.
+USES+= pkgconfig
+
+# All xorg ports needs xorg-macros.
+. if ${PORTNAME} != xorg-macros
+USE_XORG+= xorg-macros
+. endif
+
. if ${XORG_CAT} == "app"
-USE_GNOME+= pkgconfig
+# Nothing at the moment
. endif
. if ${XORG_CAT} == "data"
@@ -47,7 +56,6 @@ USE_GNOME+= pkgconfig
. endif
. if ${XORG_CAT} == "driver"
-USE_GNOME+= pkgconfig
USE_XORG+= xorg-server xproto randrproto xi
# work around a llvm bug on i386, llvm bug #15806
# reproduced with clang 3.2 (current release) and 3.1
@@ -56,11 +64,12 @@ CFLAGS+= -fno-optimize-sibling-calls
. endif
CONFIGURE_ENV+= DRIVER_MAN_SUFFIX=4x DRIVER_MAN_DIR='$$(mandir)/man4'
. if ${PORTNAME:M*input*}x != x
-USE_XORG+= inputproto renderproto
+USE_XORG+= inputproto videoproto fontsproto renderproto xextproto \
+ dri2proto
. elif ${PORTNAME:M*video*}x != x
-USE_XORG+= fontsproto renderproto
+USE_XORG+= videoproto fontsproto renderproto xextproto dri2proto
. else
-IGNORE= doesn't contain either "driver" or "input"
+IGNORE= doesn't contain either "video" or "input"
. endif
. endif
@@ -84,10 +93,9 @@ INSTALLS_TTF?= no
. endif
. if ${PORTNAME:M*font-util*}x != x
-USE_GNOME+= gnomehack
+USES+= pathfix
NEED_MKFONTFOO= no
. elif ${INSTALLS_TTF} == "yes"
-USE_GNOME+= pkgconfig
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig
. else
@@ -123,23 +131,23 @@ post-install:
. endif
. if ${XORG_CAT} == "lib"
-USE_GNOME+= gnomehack pkgconfig
+USES+= pathfix
USE_LDCONFIG= yes
CONFIGURE_ARGS+=--enable-malloc0returnsnull
. endif
. if ${XORG_CAT} == "proto"
-USE_GNOME+= gnomehack
+USES+= pathfix
. endif
. if ${XORG_CAT} == "xserver"
DISTFILES?= xorg-server-${PORTVERSION}.tar.bz2
WRKSRC= ${WRKDIR}/xorg-server-${PORTVERSION}
-USE_GNOME+= gnomehack
+USES+= pathfix
CONFIGURE_ARGS+= --with-xkb-path=${LOCALBASE}/share/X11/xkb
LIB_PC_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dri.pc:${PORTSDIR}/graphics/dri
-USE_XORG+= pciaccess
+USE_XORG+= pciaccess xextproto videoproto fontsproto dri2proto
. endif
.endif
@@ -192,6 +200,7 @@ XORG_MODULES= bigreqsproto \
xaw6 \
xaw7 \
xbitmaps \
+ xcb \
xcmiscproto \
xcomposite \
xcursor \
@@ -274,6 +283,7 @@ xaw_LIB_PC_DEPENDS= ${xaw7_LIB_PC_DEPENDS}
xaw6_LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xaw6.pc:${PORTSDIR}/x11-toolkits/libXaw
xaw7_LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xaw7.pc:${PORTSDIR}/x11-toolkits/libXaw
xbitmaps_LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xbitmaps.pc:${PORTSDIR}/x11/xbitmaps
+xcb_LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb.pc:${PORTSDIR}/x11/libxcb
xcmiscproto_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcmiscproto.pc:${PORTSDIR}/x11/xcmiscproto
xcomposite_LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcomposite.pc:${PORTSDIR}/x11/libXcomposite
xcursor_LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcursor.pc:${PORTSDIR}/x11/libXcursor