aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-16 16:11:58 +0800
committerJohn Marino <marino@FreeBSD.org>2015-03-16 16:11:58 +0800
commit71dfc66f7bc703476502139c387f81c42a1d18ae (patch)
tree930c0aaab8c8a6127d62c1db9eb638179618ade7 /Mk
parentdce1bca6b22e1a42fc5baf497d494f68b96a188e (diff)
downloadfreebsd-ports-gnome-71dfc66f7bc703476502139c387f81c42a1d18ae.tar.gz
freebsd-ports-gnome-71dfc66f7bc703476502139c387f81c42a1d18ae.tar.zst
freebsd-ports-gnome-71dfc66f7bc703476502139c387f81c42a1d18ae.zip
Mk/Uses/ada.mk: Add argument "49"
To be complete, ada.mk needs to support having ADA_DEFAULT=5 and the port explicitly requesting lang/gcc-aux. There is no identified use case for this yet, but not supporting it is a hole.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ada.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/Uses/ada.mk b/Mk/Uses/ada.mk
index fcbbb47791df..0fe47d496286 100644
--- a/Mk/Uses/ada.mk
+++ b/Mk/Uses/ada.mk
@@ -6,7 +6,7 @@
#
# Feature: ada
# Usage: USES=ada
-# Valid ARGS: 47, 5
+# Valid ARGS: 47, 49, 5
#
# MAINTAINER: marino@FreeBSD.org
@@ -17,6 +17,8 @@ CC= ada
. if ${ada_ARGS:M47}
ADAXX= gcc47
+. elif ${ada_ARGS:M49}
+ADAXX= gcc
. elif ${ada_ARGS:M5}
ADAXX= gcc5
. else