aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2012-09-21 02:25:52 +0800
committerohauer <ohauer@FreeBSD.org>2012-09-21 02:25:52 +0800
commit748b9512c699cfc67eea446642f889b133ea97c6 (patch)
tree72caabbffc36f38e49759be3201d5a4210f6b139 /Mk
parenta7d46411f93fcba7189cca0a8d10a23e2417f028 (diff)
downloadfreebsd-ports-gnome-748b9512c699cfc67eea446642f889b133ea97c6.tar.gz
freebsd-ports-gnome-748b9512c699cfc67eea446642f889b133ea97c6.tar.zst
freebsd-ports-gnome-748b9512c699cfc67eea446642f889b133ea97c6.zip
- fix issue in case no module is specified
Noted by: Adam McDougall
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.apache.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.apache.mk b/Mk/bsd.apache.mk
index df6aa1c47888..c725fffbd932 100644
--- a/Mk/bsd.apache.mk
+++ b/Mk/bsd.apache.mk
@@ -423,6 +423,7 @@ print-closest-mirrors:
.if !target(show-modules)
show-modules:
+.if !empty(APACHE_MODULES)
.for module in ${AVAILABLE_MODULES}
@${PRINTF} "%-20s : " ${module}
. if ${APACHE_MODULES:M${module}}
@@ -436,6 +437,11 @@ show-modules:
@${ECHO_CMD} disabled
. endif
.endfor
+.else
+.for module in ${AVAILABLE_MODULES}
+ @${PRINTF} "%-20s : disabled\n" ${module}
+.endfor
+.endif
.endif
.elif defined(AP_PORT_IS_MODULE)