aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-06-22 14:27:58 +0800
committermatthew <matthew@FreeBSD.org>2016-06-22 14:27:58 +0800
commit77a42de9dfbb939200f3f09469c517306faaeb26 (patch)
tree00f0c5f72ad2318d978e8151c53fe72bfed09a0e /Mk
parent38d3a78dd7943844256b36834dc31f6006dd6353 (diff)
downloadfreebsd-ports-gnome-77a42de9dfbb939200f3f09469c517306faaeb26.tar.gz
freebsd-ports-gnome-77a42de9dfbb939200f3f09469c517306faaeb26.tar.zst
freebsd-ports-gnome-77a42de9dfbb939200f3f09469c517306faaeb26.zip
WANT_PGSQL=lib adds a LIB_DEPENDS on postgresglXY-client (this is also
the default when WANT_PGSQL is not defined). Compare to WANT_PGSQL=client which only adds a RUN_DEPENDS on postgresqlXY-client. 'client' can be part of a list of different components, but 'lib' is ignored if any other terms are specified, which seems an arbitrary and incorrect restriction. WANT_PGSQL=lib allows expressing that the port links against libpq.so.X rather than just needing one of the client programs like psql(1) at runtime. However, other than that there is little practical difference between 'lib' and 'client' on the resulting pkg. Approved by: crees (pgsql@) Sponsored by: https://reviews.freebsd.org/D6893
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/pgsql.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/pgsql.mk b/Mk/Uses/pgsql.mk
index 8d38229568d5..6c37d8be01f4 100644
--- a/Mk/Uses/pgsql.mk
+++ b/Mk/Uses/pgsql.mk
@@ -130,7 +130,7 @@ IGNORE?= cannot install: does not work with postgresql${PGSQL_VER_NODOT}-client
. endfor
. endif # IGNORE_WITH_PGSQL
-.if !defined(WANT_PGSQL) || ${WANT_PGSQL} == lib
+.if !defined(WANT_PGSQL) || ${WANT_PGSQL:Mlib}
LIB_DEPENDS+= libpq.so.${PGSQL${PGSQL_VER_NODOT}_LIBVER}:databases/postgresql${PGSQL_VER_NODOT}-client
.endif