aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2010-08-07 18:56:01 +0800
committergerald <gerald@FreeBSD.org>2010-08-07 18:56:01 +0800
commit782e018dde5c52a2f6dbcfe5b0daa809cc763899 (patch)
tree976a7393eac233de5341c2610d6f81fcf7c69eb3 /Mk
parent1c37717372d7d98a258335b55427139ef2993a9b (diff)
downloadfreebsd-ports-gnome-782e018dde5c52a2f6dbcfe5b0daa809cc763899.tar.gz
freebsd-ports-gnome-782e018dde5c52a2f6dbcfe5b0daa809cc763899.tar.zst
freebsd-ports-gnome-782e018dde5c52a2f6dbcfe5b0daa809cc763899.zip
Disconnect lang/gcc43, that is, USE_GCC=4.3 is not supported any longer.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.autotools.mk6
-rw-r--r--Mk/bsd.gcc.mk7
2 files changed, 5 insertions, 8 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 20daa8684f83..2c67fa3f720f 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -105,7 +105,7 @@ AUTOMAKE_SUFFIX= ${AUTOMAKE_VERSION:C/([0-9])(.*)/\1.\2/}
# Make sure we specified a legal version of automake
#
. if !exists(${PORTSDIR}/devel/automake${AUTOMAKE_VERSION}/Makefile)
-IGNORE+= cannot install: unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
+#IGNORE+= cannot install: unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
. endif
# Set up the automake environment
@@ -151,7 +151,7 @@ AUTOCONF_SUFFIX= ${AUTOCONF_VERSION:C/([0-9])(.*)/\1.\2/}
# Make sure we specified a legal version of autoconf
#
. if !exists(${PORTSDIR}/devel/autoconf${AUTOCONF_VERSION}/Makefile)
-IGNORE+= cannot install: unknown AUTOCONF version: ${AUTOCONF_VERSION}
+#IGNORE+= cannot install: unknown AUTOCONF version: ${AUTOCONF_VERSION}
. endif
# Set up the autoconf/autoheader environment
@@ -198,7 +198,7 @@ LIBTOOL_VERSION= ${AUTOTOOL_libtool_env}
# Make sure we specified a legal version of libtool
#
. if !exists(${PORTSDIR}/devel/libtool${LIBTOOL_VERSION}/Makefile)
-IGNORE+= cannot install: unknown LIBTOOL version: ${LIBTOOL_VERSION}
+#IGNORE+= cannot install: unknown LIBTOOL version: ${LIBTOOL_VERSION}
. endif
# Set up the libtool environment
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 0dd2f4788e6f..83b6a43840a1 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -12,8 +12,7 @@
# X.Y. To request a specific version omit the trailing + sign. Use of
# a Fortran compiler is declared by the USE_FORTRAN knob, not USE_GCC.
#
-# As of 2010-06-06, USE_GCC=4.3 is deprecated and USE_GCC=4.3+ is
-# transparently rewritten to USE_GCC=4.4+.
+# As of 2010-06-06, USE_GCC=4.3+ is transparently rewritten to USE_GCC=4.4+.
#
# Examples:
# USE_GCC= 4.2+ # port requires GCC 4.2 or later.
@@ -40,14 +39,13 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
-GCCVERSIONS= 030402 040200 040300 040400 040500 040600
+GCCVERSIONS= 030402 040200 040400 040500 040600
# The first field if the OSVERSION in which it appeared in the base.
# The second field is the OSVERSION in which it disappeared from the base.
# The third field is the version as USE_GCC would use.
GCCVERSION_030402= 502126 700042 3.4
GCCVERSION_040200= 700042 999999 4.2
-GCCVERSION_040300= 999999 999999 4.3
GCCVERSION_040400= 999999 999999 4.4
GCCVERSION_040500= 999999 999999 4.5
GCCVERSION_040600= 999999 999999 4.6
@@ -117,7 +115,6 @@ MAKE_ENV+= F77="${F77}" FC="${FC}" FFLAGS="${FFLAGS}"
.if defined(USE_GCC)
-# USE_GCC=4.3 is deprecated...
.if ${USE_GCC} == "4.3+"
USE_GCC=4.4+
.endif