aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-16 00:37:31 +0800
committerbapt <bapt@FreeBSD.org>2013-03-16 00:37:31 +0800
commit7982f3e8a41e8753e766d759ba2dd0f5b5d1b050 (patch)
tree25c884ba29cba1ae9c9c4816057ef5ae0e7c71ec /Mk
parentf5ed9bc84374a940df0f1f1a771a4f1e691b2db0 (diff)
downloadfreebsd-ports-gnome-7982f3e8a41e8753e766d759ba2dd0f5b5d1b050.tar.gz
freebsd-ports-gnome-7982f3e8a41e8753e766d759ba2dd0f5b5d1b050.tar.zst
freebsd-ports-gnome-7982f3e8a41e8753e766d759ba2dd0f5b5d1b050.zip
Load features at the end of pre.mk instead of the begonning of post.mk
This allows to test/manipulates variables from USES between .pre.mk and .post.mk Having it loaded in the end of pre.mk still allows to set USES inside bsd.*.mk and after bsd.port.options.mk. The only limitation is that USES set after bsd.port.pre.mk will not be taken loaded. Which is the same behaviour as for USE_*. Requested by: bdrewery Exp-run by: miwi
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ffe6872b4eb9..d1a9754d0a9d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1527,6 +1527,15 @@ CD_MOUNTPTS?= /cdrom ${CD_MOUNTPT}
WWWOWN?= www
WWWGRP?= www
+# Loading features
+.for f in ${USES}
+_f=${f:C/\:.*//g}
+.if ${_f} != ${f}
+${_f}_ARGS:= ${f:C/^[^\:]*\://g}
+.endif
+.include "${USESDIR}/${_f}.mk"
+.endfor
+
.endif
# End of pre-makefile section.
@@ -1541,15 +1550,6 @@ check-makefile::
_POSTMKINCLUDED= yes
-# Loading features
-.for f in ${USES}
-_f=${f:C/\:.*//g}
-.if ${_f} != ${f}
-${_f}_ARGS:= ${f:C/^[^\:]*\://g}
-.endif
-.include "${USESDIR}/${_f}.mk"
-.endfor
-
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
.if !defined(IGNORE_MASTER_SITE_GITHUB) && defined(USE_GITHUB)
WRKSRC?= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}