aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerAlex Dupre <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit7fe96c109332ecdb411ceef911efd11085a88346 (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /Mk
parent47b48988aa7fe1c1c0f221ce9cb124af07f62a16 (diff)
downloadfreebsd-ports-gnome-7fe96c109332ecdb411ceef911efd11085a88346.tar.gz
freebsd-ports-gnome-7fe96c109332ecdb411ceef911efd11085a88346.tar.zst
freebsd-ports-gnome-7fe96c109332ecdb411ceef911efd11085a88346.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.php.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 63eb9e8f23db..4f57094e895f 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -53,6 +53,9 @@ PHP_EXT_DIR= 20060613
.elif ${PHP_VER} == 53
PHP_EXT_DIR= 20090626
PHP_EXT_INC= pcre spl
+.elif ${PHP_VER} == 55
+PHP_EXT_DIR= 20121212
+PHP_EXT_INC= pcre spl
.else
PHP_EXT_DIR= 20100525
PHP_EXT_INC= pcre spl
@@ -268,6 +271,7 @@ _USE_PHP_ALL= apc bcmath bitset bz2 calendar ctype curl dba dom \
_USE_PHP_VER5= ${_USE_PHP_ALL} phar sqlite3
_USE_PHP_VER52= ${_USE_PHP_ALL} dbase mhash ming ncurses oci8 sqlite
_USE_PHP_VER53= ${_USE_PHP_ALL} phar sqlite sqlite3
+_USE_PHP_VER55= ${_USE_PHP_ALL} phar sqlite3
apc_DEPENDS= www/pecl-APC
bcmath_DEPENDS= math/php${PHP_VER}-bcmath