aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-05-08 08:12:08 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-05-08 08:12:08 +0800
commit813c979345062e9731c60a469a0180323f87f35d (patch)
tree6b1e1e45026bc594b96dd90c4a38a894b5cf7043 /Mk
parent8eb1a6d9083f6901085fd37dc957b9f978db0752 (diff)
downloadfreebsd-ports-gnome-813c979345062e9731c60a469a0180323f87f35d.tar.gz
freebsd-ports-gnome-813c979345062e9731c60a469a0180323f87f35d.tar.zst
freebsd-ports-gnome-813c979345062e9731c60a469a0180323f87f35d.zip
- Follow-up to r317320: fix MAKE_JOBS_NUMBER not being set
if none of DISABLE_MAKE_JOBS or MAKE_JOBS_UNSAFE or MAKE_JOBS_SAFE or FORCE_MAKE_JOBS were set. This fixes the build for several ports updated in r317320. Reported by: miwi With hat: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a77befe7b451..9363117e0121 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2159,7 +2159,6 @@ CFLAGS:= ${CFLAGS:N-std=*} -std=${USE_CSTD}
# Multiple make jobs support
.if defined(DISABLE_MAKE_JOBS) || defined(MAKE_JOBS_UNSAFE)
-MAKE_JOBS_NUMBER= 1
_MAKE_JOBS= #
.else
.if defined(MAKE_JOBS_SAFE) || defined(FORCE_MAKE_JOBS)
@@ -2171,6 +2170,10 @@ BUILD_FAIL_MESSAGE+= "You have chosen to use multiple make jobs (parallelization
.endif
.endif
+.if empty(MAKE_JOBS_NUMBER)
+MAKE_JOBS_NUMBER= 1
+.endif
+
# ccache support
# Support NO_CCACHE for common setups, require WITH_CCACHE_BUILD, and
# don't use if ccache already set in CC