aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-01 02:51:45 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-03-01 02:51:45 +0800
commit87378368c4cd9d84e237f7da415b7dac422158ae (patch)
tree692346311e6ea5e3a20aa4de86fc4c034fef9753 /Mk
parentf8eead936c09b69171b6fdb83823ed3d9973b5af (diff)
downloadfreebsd-ports-gnome-87378368c4cd9d84e237f7da415b7dac422158ae.tar.gz
freebsd-ports-gnome-87378368c4cd9d84e237f7da415b7dac422158ae.tar.zst
freebsd-ports-gnome-87378368c4cd9d84e237f7da415b7dac422158ae.zip
lang/rust: update to 1.33.0
- www/firefox temporarily loses SIMD in charset conversion, see https://bugzilla.mozilla.org/show_bug.cgi?id=1521249 - Force rebuild all consumers to catch regressions early Changes: https://blog.rust-lang.org/2019/02/28/Rust-1.33.0.html Tested by: Mikaƫl Urankar (aarch64, armv6, armv7, powerpc64), Piotr Kubaj (powerpc64) Approved by: rust (tobik) Differential Revision: https://reviews.freebsd.org/D19354
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk2
-rw-r--r--Mk/bsd.gecko.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index 7c5a56b901ab..a77c85418cbe 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -43,7 +43,7 @@ DISTFILES+= ${CARGO_DIST_SUBDIR}/${_crate}.tar.gz:cargo_${_crate:S/-//g:S/.//g}
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.32.0:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.33.0:lang/${RUST_DEFAULT}
.endif
# Location of cargo binary (default to lang/rust's Cargo binary)
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index d21d52b59f49..f9d12bf5e425 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -355,7 +355,7 @@ MOZ_OPTIONS+= --enable-debug --disable-release
STRIP= # ports/184285
.else
MOZ_OPTIONS+= --disable-debug --disable-debug-symbols --enable-release
-. if ${MOZILLA_VER:R:R} >= 56 && (${ARCH:Maarch64} || ${MACHINE_CPU:Msse2})
+. if ${MOZILLA_VER:R:R} >= 67 && (${ARCH:Maarch64} || ${MACHINE_CPU:Msse2})
MOZ_OPTIONS+= --enable-rust-simd
. endif
.endif