aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-07-29 15:01:20 +0800
committerbapt <bapt@FreeBSD.org>2013-07-29 15:01:20 +0800
commit8c948d04b26cc6e19e1197ca83696b3f9999a9d7 (patch)
treea609832517ae02d26726d505e999fd9babfe2033 /Mk
parentd452ce8663cf11e64f10ba089d89f757fe1fb297 (diff)
downloadfreebsd-ports-gnome-8c948d04b26cc6e19e1197ca83696b3f9999a9d7.tar.gz
freebsd-ports-gnome-8c948d04b26cc6e19e1197ca83696b3f9999a9d7.tar.zst
freebsd-ports-gnome-8c948d04b26cc6e19e1197ca83696b3f9999a9d7.zip
Add new ${OPT}_CONFIGURE_WITH option help
it will handle the --with/--without configure argument dancing based on the value of the OPTION ${OPT} Requested by: mandree
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 0fb3e40d9128..43fc86558fb7 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -351,6 +351,9 @@ PLIST_SUB:= ${PLIST_SUB} ${opt}="@comment "
. if defined(${opt}_CONFIGURE_ENABLE)
CONFIGURE_ARGS+= --enable-${${opt}_CONFIGURE_ENABLE}
. endif
+. if defined(${opt}_CONFIGURE_WITH)
+CONFIGURE_ARGS+= --with-${${opt}_CONFIGURE_WITH}
+. endif
. if defined(${opt}_CONFIGURE_ON)
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_ON}
. endif
@@ -371,6 +374,9 @@ ${deptype}_DEPENDS+= ${${opt}_${deptype}_DEPENDS}
. if defined(${opt}_CONFIGURE_ENABLE)
CONFIGURE_ARGS+= --disable-${${opt}_CONFIGURE_ENABLE}
. endif
+. if defined(${opt}_CONFIGURE_WITH)
+CONFIGURE_ARGS+= --without-${${opt}_CONFIGURE_WITH}
+. endif
. if defined(${opt}_CONFIGURE_OFF)
CONFIGURE_ARGS+= ${${opt}_CONFIGURE_OFF}
. endif