aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-05-02 23:00:12 +0800
committermat <mat@FreeBSD.org>2017-05-02 23:00:12 +0800
commit90f07c1acce89491b80cc5ff69e6394d41c23e86 (patch)
tree3a4acdf346534221e5217ae89fdef4f1b7cabb0f /Mk
parent4aa7f7efafc736cb961dbc7e9f1e48de0c68363e (diff)
downloadfreebsd-ports-gnome-90f07c1acce89491b80cc5ff69e6394d41c23e86.tar.gz
freebsd-ports-gnome-90f07c1acce89491b80cc5ff69e6394d41c23e86.tar.zst
freebsd-ports-gnome-90f07c1acce89491b80cc5ff69e6394d41c23e86.zip
Enable depending on Perl only during the test phase.
Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 7dc8369c3bf7..d4e6de2b1311 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -26,7 +26,7 @@
# SITE_ARCH - Directory name where arch site specific perl packages go.
# This value is added to PLIST_SUB.
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
-# patch, build, install or run phases.
+# patch, build, run or test phases.
# It can also have configure, modbuild and modbuildtiny when
# the port needs to run Makefile.PL, Build.PL and a
# Module::Build::Tiny flavor of Build.PL.
@@ -244,6 +244,10 @@ BUILD_DEPENDS+= ${PERL5_DEPEND}:lang/${PERL_PORT}
RUN_DEPENDS+= ${PERL5_DEPEND}:lang/${PERL_PORT}
. endif
+. if ${_USE_PERL5:Mtest}
+TEST_DEPENDS+= ${PERL5_DEPEND}:lang/${PERL_PORT}
+. endif
+
. if ${_USE_PERL5:Mconfigure}
CONFIGURE_ARGS+= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"