aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2012-02-24 21:08:32 +0800
committeravilla <avilla@FreeBSD.org>2012-02-24 21:08:32 +0800
commit92a10b7c3b292d1db68a4d208982de8769de7d43 (patch)
tree9915fe4362cf4f1bed2446fa11c80b5a5f282c6a /Mk
parent925ba7e0afc4387863167fa6f0d8dffded94712b (diff)
downloadfreebsd-ports-gnome-92a10b7c3b292d1db68a4d208982de8769de7d43.tar.gz
freebsd-ports-gnome-92a10b7c3b292d1db68a4d208982de8769de7d43.tar.zst
freebsd-ports-gnome-92a10b7c3b292d1db68a4d208982de8769de7d43.zip
- Fix definition of PREFIX and NO_MTREE.
As noted in the file, PREFIX and NO_MTREE need to be defined in the pre-makefile section, as PREFIX is checked prior to the end of the section (in bsd.port.mk), and NO_MTREE in the post-makefile section (in bsd.port.mk and other *.mk files). The "error" (it was actually an annoyance, but could have been worse) was triggered when updating KDE ports using the new WITH_PKGNG switch (bsd.pkgng.mk, also bugged in a similar way at the time, resolved the value of NO_MTREE prior to its definition in bsd.kde4.mk).
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.kde4.mk21
1 files changed, 11 insertions, 10 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index 4c534c069c14..54a90afe0c8a 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -86,6 +86,17 @@ _USE_KDE4_ALL= akonadi automoc4 baseapps kdebase kdehier kdelibs kdeprefix \
oxygen pimlibs pimruntime pykde4 pykdeuic4 runtime \
sharedmime workspace
+# We need to set it here (and not at the bottom) because PREFIX and
+# NO_MTREE have to be defined in pre-makefile section.
+.if ${USE_KDE4:Mkdeprefix} != ""
+. if ${.MAKEFLAGS:MPREFIX=*} == ""
+PREFIX= ${KDE4_PREFIX}
+. if ${KDE4_PREFIX} != ${LOCALBASE}
+NO_MTREE= yes
+. endif
+. endif
+.endif
+
akonadi_LIB_DEPENDS= akonadiprotocolinternals.1:${PORTSDIR}/databases/akonadi
automoc4_BUILD_DEPENDS= ${LOCALBASE}/bin/automoc4:${PORTSDIR}/devel/automoc4
@@ -97,8 +108,6 @@ kdehier_RUN_DEPENDS= kdehier4>=1:${PORTSDIR}/misc/kdehier4
kdelibs_LIB_DEPENDS= kimproxy.5:${PORTSDIR}/x11/kdelibs4
-kdeprefix_PREFIX= ${KDE4_PREFIX}
-
oxygen_RUN_DEPENDS= ${KDE4_PREFIX}/share/icons/oxygen/index.theme:${PORTSDIR}/x11-themes/kde4-icons-oxygen
pimlibs_LIB_DEPENDS= kpimutils.5:${PORTSDIR}/deskutils/kdepimlibs4
@@ -164,14 +173,6 @@ Kde_Post_Include= bsd.kde4.mk
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
-. if defined(${component}_PREFIX)
-. if ${.MAKEFLAGS:MPREFIX=*}==""
-PREFIX= ${${component}_PREFIX}
-. if ${KDE4_PREFIX} != ${LOCALBASE}
-NO_MTREE= yes
-. endif
-. endif
-. endif
. else
IGNORE= cannot install: Unknown component ${component}
. endif