aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 05:05:14 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 05:05:14 +0800
commit9b17397fe093d41486f2ef131dbe24c1f3068bb4 (patch)
tree9ca6ac460b5078ad6bada0aa77e52a5af436cd41 /Mk
parent4f48d08c11e5b1c4fa10a5f48269d7ba05a28851 (diff)
downloadfreebsd-ports-gnome-9b17397fe093d41486f2ef131dbe24c1f3068bb4.tar.gz
freebsd-ports-gnome-9b17397fe093d41486f2ef131dbe24c1f3068bb4.tar.zst
freebsd-ports-gnome-9b17397fe093d41486f2ef131dbe24c1f3068bb4.zip
New USES=motif that will handle the open-motif dependency.
If a user want to enforce lesstif in place of open-motif then the usual WANT_LESSTIF in make.conf will be respected
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/motif.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/Mk/Uses/motif.mk b/Mk/Uses/motif.mk
new file mode 100644
index 000000000000..4e2ea0ad4cd8
--- /dev/null
+++ b/Mk/Uses/motif.mk
@@ -0,0 +1,30 @@
+# $FreeBSD$
+#
+# handle dependency on motif
+#
+# MAINTAINER: portmgr@FreeBSD.org
+#
+# Feature: motif
+# Usage: USES=motif
+#
+# If WANT_LESSTIF is defined in user make.conf then lesstif will be used
+# instead of open-motif
+
+.if !defined(_INCLUDE_USES_MOTIF_MK)
+_INCLUDE_USES_MOTIF_MK= yes
+
+.if defined(motif_ARGS)
+IGNORE= USES=motif takes no arguments
+.endif
+
+.if defined(WANT_LESSTIF)
+LIB_DEPENDS+= libXm.so:${PORTSDIR}/x11-toolkits/lesstif
+.else
+USE_XORG+= xpm
+LIB_DEPENDS+= libXm.so.4:${PORTSDIR}/x11-toolkits/open-motif
+.endif
+
+MOTIFLIB?= -L${LOCALBASE}/lib -lXm -lXp
+MAKE_ENV+= MOTIFLIB="${MOTIFLIB}"
+
+.endif