aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-18 00:03:43 +0800
committermat <mat@FreeBSD.org>2016-06-18 00:03:43 +0800
commita1d77ddff7f5338c4e52604d488e784aeb69c80e (patch)
tree26e62961f9f6943e32f62483e64aadc841c918d3 /Mk
parent81b3062f2f38bec79dae3c32ac83dba8eb7e27ff (diff)
downloadfreebsd-ports-gnome-a1d77ddff7f5338c4e52604d488e784aeb69c80e.tar.gz
freebsd-ports-gnome-a1d77ddff7f5338c4e52604d488e784aeb69c80e.tar.zst
freebsd-ports-gnome-a1d77ddff7f5338c4e52604d488e784aeb69c80e.zip
Fix targets being out of order.
Reported by: antoine Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.autotools.mk19
1 files changed, 9 insertions, 10 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index e4b2d4b9dc3b..4cca0ef56e26 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -190,29 +190,28 @@ ${var:tu}_ENV+= ${AUTOTOOLS_VARS}
# Make targets
#---------------------------------------------------------------------------
+_USES_configure+=460:run-autotools-aclocal 461:run-autotools-autoconf \
+ 462:run-autotools-autoheader 463:run-autotools-automake
+
.if defined(_AUTOTOOL_rule_aclocal) && !target(run-autotools-aclocal)
-_USES_configure+= 460:run-autotools-aclocal
run-autotools-aclocal:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
${ACLOCAL_ARGS})
.endif
-.if defined(_AUTOTOOL_rule_automake) && !target(run-autotools-automake)
-_USES_configure+= 461:run-autotools-autoconf
-run-autotools-automake:
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
- ${AUTOMAKE_ARGS})
-.endif
-
.if defined(_AUTOTOOL_rule_autoconf) && !target(run-autotools-autoconf)
-_USES_configure+= 462:run-autotools-autoheader
run-autotools-autoconf:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} \
${AUTOCONF_ARGS})
.endif
+.if defined(_AUTOTOOL_rule_automake) && !target(run-autotools-automake)
+run-autotools-automake:
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
+ ${AUTOMAKE_ARGS})
+.endif
+
.if defined(_AUTOTOOL_rule_autoheader) && !target(run-autotools-autoheader)
-_USES_configure+= 463:run-autotools-automake
run-autotools-autoheader:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} \
${AUTOHEADER_ARGS})