aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-06-23 02:57:33 +0800
committerpi <pi@FreeBSD.org>2016-06-23 02:57:33 +0800
commita836abdb781bb3cb763c704e120c2a3266d97f84 (patch)
tree14a0f2235807b33e86dc0ec99cb4ac26ed7f003d /Mk
parentdd65a4bdca31f99c9187c84ba9a67b545c4f45f0 (diff)
downloadfreebsd-ports-gnome-a836abdb781bb3cb763c704e120c2a3266d97f84.tar.gz
freebsd-ports-gnome-a836abdb781bb3cb763c704e120c2a3266d97f84.tar.zst
freebsd-ports-gnome-a836abdb781bb3cb763c704e120c2a3266d97f84.zip
x11/kde4: update to kdelibs version 4.14.10
This is based on the area51 testing repository of the KDE-FreeBSD project, containing work by Raphael Kubo da Costa, Tobias Berner, Ralf Nolden, Adriaan de Groot and probably many more from the KDE team. KDE4 releases have fallen into three tracks now that KDE4 is pretty much end-of-life upstream. There's the libraries, the workspace (Plasma4) and applications. This patch introduces KDE4_KDELIBS_VERSION to track library releases, which are still done infrequently. It bumps the workspace version. It leaves applications alone. This has an effect on some applications pkg-plists where library version numbers need to be changed. Other than that it's supposed to be a minor upgrade, which opens the doors for more reorganization and getting KDE Frameworks 5 in. PR: 210255 Submitted by: Adriaan de Groot <groot@kde.org> (kde), Tobias C.Berner <tcberner@gmail.com> (kde) Exp-run by: antoine
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.kde4.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index b894399cb17d..0c013255238b 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -74,8 +74,9 @@ Kde_Pre_Include= bsd.kde4.mk
#
KDE4_VERSION?= 4.14.3
+KDE4_KDELIBS_VERSION= 4.14.10
KDE4_ACTIVITES_VERSION= 4.13.3
-KDE4_WORKSPACE_VERSION= 4.11.14
+KDE4_WORKSPACE_VERSION= 4.11.21
KDE4_APPLICATIONS_VERSION?= 15.04.3
KDE4_APPLICATIONS_BRANCH?= Attic
KDE4_BRANCH?= stable
@@ -94,8 +95,11 @@ CMAKE_ARGS+= -DCMAKE_PREFIX_PATH="${LOCALBASE};${KDE4_PREFIX}" \
PLIST_SUB+= KDE4_PREFIX="${KDE4_PREFIX}" \
KDE4_VERSION="${KDE4_VERSION}" \
- KDE4_GENERIC_LIB_VERSION=${KDE4_VERSION} \
- KDE4_NON_GENERIC_LIB_VERSION=${KDE4_VERSION:S,^4,5,}
+ KDE4_GENERIC_LIB_VERSION=${KDE4_KDELIBS_VERSION} \
+ KDE4_NON_GENERIC_LIB_VERSION=${KDE4_KDELIBS_VERSION:S,^4,5,} \
+ KDE4_KDELIBS_VERSION=${KDE4_KDELIBS_VERSION} \
+ KDE4_NG_KDELIBS_VERSION=${KDE4_KDELIBS_VERSION:S,^4,5,}
+
# Keep in sync with cmake/modules/PythonMacros.cmake
_PYTHON_SHORT_VER= ${PYTHON_VERSION:S/^python//:S/.//}