aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-04-04 06:11:52 +0800
committerbapt <bapt@FreeBSD.org>2014-04-04 06:11:52 +0800
commitabc3d4f7c502b1272cde6eed85dacdd9862051be (patch)
tree0d8c3c727e2c8a9b0b89b3065a563ee46d80933c /Mk
parent1b540346739841a10e6ae2b8a486d594d343e596 (diff)
downloadfreebsd-ports-gnome-abc3d4f7c502b1272cde6eed85dacdd9862051be.tar.gz
freebsd-ports-gnome-abc3d4f7c502b1272cde6eed85dacdd9862051be.tar.zst
freebsd-ports-gnome-abc3d4f7c502b1272cde6eed85dacdd9862051be.zip
Prepend install(1) command with the STRIPBIN env defined to the proper STRIPBIN to allow cross-installation
Reported by: ian
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 87fecab5e802..0b0a1584d3fc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2210,11 +2210,11 @@ _MANOWNGRP=
# A few aliases for *-install targets
INSTALL_PROGRAM= \
- ${INSTALL} ${COPY} ${STRIP} ${_BINOWNGRP} -m ${BINMODE}
+ STRIPBIN=${STRIP_CMD} ${INSTALL} ${COPY} ${STRIP} ${_BINOWNGRP} -m ${BINMODE}
INSTALL_KLD= \
${INSTALL} ${COPY} ${_BINOWNGRP} -m ${BINMODE}
INSTALL_LIB= \
- ${INSTALL} ${COPY} ${STRIP} ${_SHROWNGRP} -m ${SHAREMODE}
+ STRIPBIN=${STRIP_CMD}${INSTALL} ${COPY} ${STRIP} ${_SHROWNGRP} -m ${SHAREMODE}
INSTALL_SCRIPT= \
${INSTALL} ${COPY} ${_BINOWNGRP} -m ${BINMODE}
INSTALL_DATA= \