aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-12-04 19:07:04 +0800
committerMathieu Arnold <mat@FreeBSD.org>2017-12-04 19:07:04 +0800
commitae164d1dfd455f640ec67eda862afe373136cf7a (patch)
treebd9c77e847ee6c4277c6530c9cc56dc1bdab3eee /Mk
parenta36112d51ae5687683f59bdb0ab3c7f23522e7e5 (diff)
downloadfreebsd-ports-gnome-ae164d1dfd455f640ec67eda862afe373136cf7a.tar.gz
freebsd-ports-gnome-ae164d1dfd455f640ec67eda862afe373136cf7a.tar.zst
freebsd-ports-gnome-ae164d1dfd455f640ec67eda862afe373136cf7a.zip
Add a WARNING for people trying to do clever but bad things with Python
versions. Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index fd2b8713bb03..9cd7bf7c8ad1 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -302,6 +302,10 @@ WARNING+= "PYTHON2_DEFAULT_VERSION is defined, consider using DEFAULT_VERSIONS=p
WARNING+= "PYTHON3_DEFAULT_VERSION is defined, consider using DEFAULT_VERSIONS=python3=${PYTHON3_DEFAULT_VERSION:S/^python//} instead"
.endif
+.if ${PYTHON2_DEFAULT} != ${PYTHON_DEFAULT} && ${PYTHON3_DEFAULT} != ${PYTHON_DEFAULT}
+WARNING+= "PYTHON_DEFAULT must be a version present in PYTHON2_DEFAULT or PYTHON3_DEFAULT, if you want more Python flavors, set BUILD_ALL_PYTHON_FLAVORS in your make.conf"
+.endif
+
.if exists(${LOCALBASE}/bin/python)
.if !defined(_PYTHON_DEFAULT_VERSION)
_PYTHON_DEFAULT_VERSION!= (${LOCALBASE}/bin/python -c \