aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-08-04 20:12:55 +0800
committerbapt <bapt@FreeBSD.org>2014-08-04 20:12:55 +0800
commitaec2fef6b8880e0f7d35f19a1d54d9e1747ee767 (patch)
treeddde1853f59be44124c159b85751b161ed2cd0c4 /Mk
parent5e17b9936d359cb1f2a3ac0c261a290c5b8ba0c7 (diff)
downloadfreebsd-ports-gnome-aec2fef6b8880e0f7d35f19a1d54d9e1747ee767.tar.gz
freebsd-ports-gnome-aec2fef6b8880e0f7d35f19a1d54d9e1747ee767.tar.zst
freebsd-ports-gnome-aec2fef6b8880e0f7d35f19a1d54d9e1747ee767.zip
Add make missing-package that will do the same as make missing but print package
names rather than origin PR: 177230 Submitted by: ehaupt
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a6ed0b96b050..0e596f3d7f00 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5327,6 +5327,16 @@ missing:
fi; \
done
+# shwo missing dependencies by name
+missing-packages:
+ @_packages=$$(${PKG_INFO} -aq); \
+ for dir in $$(${ALL-DEPENDS-LIST}); do \
+ _p=$$(cd $$dir; ${MAKE} -VPKGNAME); \
+ if ! $$(${ECHO_CMD} $${_packages} | ${GREP} -q $${_p}); then \
+ ${ECHO_CMD} $${_p}; \
+ fi; \
+ done
+
################################################################
# Everything after here are internal targets and really
# shouldn't be touched by anybody but the release engineers.