aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2012-01-22 23:41:33 +0800
committerbeat <beat@FreeBSD.org>2012-01-22 23:41:33 +0800
commitbfcb8fb7ed97ea804392b596769d9a120912d4db (patch)
treea77acde2bfc4cc8632a0c0d5174e330343689d5a /Mk
parent37897c364ef106df2ec58c958573107d608e736b (diff)
downloadfreebsd-ports-gnome-bfcb8fb7ed97ea804392b596769d9a120912d4db.tar.gz
freebsd-ports-gnome-bfcb8fb7ed97ea804392b596769d9a120912d4db.tar.zst
freebsd-ports-gnome-bfcb8fb7ed97ea804392b596769d9a120912d4db.zip
- Apply FreeBSD 10.x workaround on WRKDIR instead of WRKSRC as some ports
provide their configure script outside of WRKSRC. - Print out all files on which the autotools fix was applied. Exp-runs by: miwi
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 241cf589fa19..53d60444ec33 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3654,7 +3654,7 @@ do-patch:
run-autotools-fixup:
# Work around an issue where FreeBSD 10.0 is detected as FreeBSD 1.x.
.if ${OSVERSION} >= 1000000 && !defined(WITHOUT_FBSD10_FIX)
- -@for f in `${FIND} ${WRKSRC} -type f \( -name config.libpath -o \
+ -@for f in `${FIND} ${WRKDIR} -type f \( -name config.libpath -o \
-name config.rpath -o -name configure -o -name libtool.m4 -o \
-name ltconfig -o -name libtool -o -name aclocal.m4 -o \
-name acinclude.m4 \)` ; do \
@@ -3666,6 +3666,8 @@ run-autotools-fixup:
-e 's|freebsd\[\[123\]\]\*)|freebsd[[123]].*)|g' \
$${f} ; \
${TOUCH} ${TOUCH_FLAGS} -mr $${f}.fbsd10bak $${f} ; \
+ ${RM} -f $${f}.fbsd10bak ; \
+ ${ECHO_MSG} "===> FreeBSD 10 autotools fix applied to $${f}"; \
done
.endif
.endif