aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-09-03 13:16:13 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-09-03 13:16:13 +0800
commitc4526308ea8298676eba125fb32c557f7ba39893 (patch)
tree049ffcb5b571194aa7324281882d2623d6a9cf5d /Mk
parent4763c7d4d0875adaeda5496d358ccd5f4c4dd778 (diff)
downloadfreebsd-ports-gnome-c4526308ea8298676eba125fb32c557f7ba39893.tar.gz
freebsd-ports-gnome-c4526308ea8298676eba125fb32c557f7ba39893.tar.zst
freebsd-ports-gnome-c4526308ea8298676eba125fb32c557f7ba39893.zip
Convert rmtry into regular Keyword
Note that this allows to control when it is executed (always in post-installation) This makes @rmtry accept both absolute path and relative path (to latest prefix/cwd) While here now that it is not used, remove the old PLIST_REINPLACE macro Reviewed by: antoine Differential Revision: https://reviews.freebsd.org/D713
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk9
1 files changed, 0 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index adc6424ce243..f631c37b2c9b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1601,9 +1601,6 @@ SUB_LIST+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
PLIST_SUB_SED_MIN?= 2
PLIST_SUB_SED?= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
-PLIST_REINPLACE+= rmtry
-PLIST_REINPLACE_RMTRY=s!^@rmtry \(.*\)!@unexec rm -f %D/\1 2>/dev/null || true!
-
# kludge to strip trailing whitespace from CFLAGS;
# sub-configure will not # survive double space
CFLAGS:= ${CFLAGS:C/ $//}
@@ -5321,12 +5318,6 @@ generate-plist: ${WRKDIR}
@${ECHO_CMD} ${dir} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} -e 's,^,@dirrmtry ,' >> ${TMPPLIST}
.endfor
-.for reinplace in ${PLIST_REINPLACE}
-.if defined(PLIST_REINPLACE_${reinplace:tu})
- @${SED} -i "" -e '${PLIST_REINPLACE_${reinplace:tu}}' ${TMPPLIST}
-.endif
-.endfor
-
.if defined(USE_LINUX_PREFIX)
.if defined(USE_LDCONFIG)
@${ECHO_CMD} "@exec ${LDCONFIG_CMD}" >> ${TMPPLIST}