aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-08-28 05:52:25 +0800
committermandree <mandree@FreeBSD.org>2014-08-28 05:52:25 +0800
commitc63c3e2c95fe49ba810f7bdbbc7a3cdd96d975ce (patch)
tree2ad7e9acb81b053c18dabe6703927bbee56616da /Mk
parent03bc23f2e62d0f00a8bd129df9103e0adb16c696 (diff)
downloadfreebsd-ports-gnome-c63c3e2c95fe49ba810f7bdbbc7a3cdd96d975ce.tar.gz
freebsd-ports-gnome-c63c3e2c95fe49ba810f7bdbbc7a3cdd96d975ce.tar.zst
freebsd-ports-gnome-c63c3e2c95fe49ba810f7bdbbc7a3cdd96d975ce.zip
Fix @dirrm auto-generation for PORTDOCS/PORTEXAMPLES/PORTDATA with globs.
Fix up net-mgmt/netmond pkg-plist for @mode (regression with pkg from r347404 committed by rene@) and remove two @dirrm lines that are now excess. Exp-run completed. PR: 191746 Reviewed by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 398279934440..28cdea6b7362 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -645,6 +645,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Should not be set when no documentation files are
# installed.
# Useful for dynamically generated documentation.
+# NOTE: this may fail to generate @dirrm entries for
+# complex patterns. In such a case, please abstain from
+# using DOCSDIR and add files and @dirrm-directories to
+# pkg-plist instead (see make makeplist).
#
# Set the following to specify all documentation your port installs into
# ${EXAMPLESDIR}
@@ -5555,7 +5559,7 @@ add-plist-docs:
.endfor
@${FIND} -P ${PORTDOCS:S/^/${STAGEDIR}${DOCSDIR}\//} ! -type d 2>/dev/null | \
${SED} -ne 's,^${STAGEDIR}${PREFIX}/,,p' >> ${TMPPLIST}
- @${FIND} -P -d ${PORTDOCS:S/^/${STAGEDIR}${DOCSDIR}\//} -type d 2>/dev/null | \
+ @${FIND} -P -d ${PORTDOCS:S/^/${STAGEDIR}${DOCSDIR}\//:C,/[^/]*[*?\[][^/]*$,,} -type d 2>/dev/null | \
${SED} -ne 's,^${STAGEDIR}${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm ${DOCSDIR_REL}" >> ${TMPPLIST}
.endif
@@ -5577,7 +5581,7 @@ add-plist-examples:
.endfor
@${FIND} -P ${PORTEXAMPLES:S/^/${STAGEDIR}${EXAMPLESDIR}\//} ! -type d 2>/dev/null | \
${SED} -ne 's,^${STAGEDIR}${PREFIX}/,,p' >> ${TMPPLIST}
- @${FIND} -P -d ${PORTEXAMPLES:S/^/${STAGEDIR}${EXAMPLESDIR}\//} -type d 2>/dev/null | \
+ @${FIND} -P -d ${PORTEXAMPLES:C,/[^/]*[*?\[][^/]*$,,:S/^/${STAGEDIR}${EXAMPLESDIR}\//} -type d 2>/dev/null | \
${SED} -ne 's,^${STAGEDIR}${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm ${EXAMPLESDIR_REL}" >> ${TMPPLIST}
.endif
@@ -5599,7 +5603,7 @@ add-plist-data:
.endfor
@${FIND} -P ${PORTDATA:S/^/${STAGEDIR}${DATADIR}\//} ! -type d 2>/dev/null | \
${SED} -ne 's,^${STAGEDIR}${PREFIX}/,,p' >> ${TMPPLIST}
- @${FIND} -P -d ${PORTDATA:S/^/${STAGEDIR}${DATADIR}\//} -type d 2>/dev/null | \
+ @${FIND} -P -d ${PORTDATA:C,/[^/]*[*?\[][^/]*$,,:S/^/${STAGEDIR}${DATADIR}\//} -type d 2>/dev/null | \
${SED} -ne 's,^${STAGEDIR}${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm ${DATADIR_REL}" >> ${TMPPLIST}
.endif