aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committermakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitcdb81da9cb2b58e688594b552337d1c9bfc47e96 (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /Mk
parent904fc890d1dc712abfaeaddde7864519df50915c (diff)
downloadfreebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.gz
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.zst
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.kde4.mk31
1 files changed, 2 insertions, 29 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index f6d1a99bbbf8..8794d9b78e0a 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -102,7 +102,8 @@ NO_MTREE= yes
. endif
.endif
-PLIST_SUB+= KDE4_PREFIX="${KDE4_PREFIX}"
+PLIST_SUB+= KDE4_PREFIX="${KDE4_PREFIX}" \
+ KDE4_VERSION="${KDE4_VERSION}"
# Keep in sync with cmake/modules/PythonMacros.cmake
_PYTHON_SHORT_VER= ${PYTHON_VERSION:S/^python//:S/.//}
@@ -116,34 +117,6 @@ PLIST_SUB+= PYCACHE="" \
PYO_SUFFIX=pyo
.endif
-# The following definitions are not intended for usage in KDE4-dependent ports.
-.if defined(KDE4_BUILDENV)
-
-USE_CMAKE= yes
-CMAKE_SOURCE_PATH= ${WRKSRC}
-USE_LDCONFIG= yes
-
-. if ${KDE4_BRANCH} == "unstable"
-WITH_DEBUG= yes
-. endif
-
-. if defined(WITH_DEBUG)
-CMAKE_BUILD_TYPE= DebugFull
-. endif
-
-PLIST_SUB+= KDE4_VERSION="${KDE4_VERSION}"
-
-CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
-BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
-INSTALL_WRKSRC?= ${BUILD_WRKSRC}
-
-post-extract: kde4-create-builddir
-
-kde4-create-builddir:
- ${MKDIR} ${BUILD_WRKSRC}
-
-.endif # defined(KDE4_BUILDENV)
-
.endif # !defined(_POSTMKINCLUDED) && !defined(Kde_Pre_Include)
.if defined(_POSTMKINCLUDED) && !defined(Kde_Post_Include)