aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2006-12-13 11:22:22 +0800
committeralexbl <alexbl@FreeBSD.org>2006-12-13 11:22:22 +0800
commitce4554fb85dc1fee85e8f32cd64b6ac839733a2b (patch)
tree7f2465485ed8b3857432025290a8b8337fbaf46c /Mk
parentb2792a2818d743a3f1c238214ca541381fd6c28b (diff)
downloadfreebsd-ports-gnome-ce4554fb85dc1fee85e8f32cd64b6ac839733a2b.tar.gz
freebsd-ports-gnome-ce4554fb85dc1fee85e8f32cd64b6ac839733a2b.tar.zst
freebsd-ports-gnome-ce4554fb85dc1fee85e8f32cd64b6ac839733a2b.zip
- add ${PYHASHLIB} dependency macro to bsd.python.mk
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 6c02eb096d7f..d584cb789b81 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -110,6 +110,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYCTYPES - Dependency line for the ctypes package. As of Python-2.5,
# this module is in the base distribution.
#
+# PYHASHLIB - Dependency line for the hashlib package. As of Python-2.5,
+# this module is in the base distribution.
+#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -441,6 +444,12 @@ PYCTYPES= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
PYCTYPES= ${PYTHON_LIBDIR}/ctypes/__init__py:${PYTHON_PORTSDIR}
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
+PYHASHLIB= ${PYTHON_SITELIBDIR}/hashlib.py:${PORTSDIR}/security/py-hashlib
+.else
+PYHASHLIB= ${PYTHON_LIBDIR}/hashlib.py:${PYTHON_PORTSDIR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO