aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-09-28 22:19:30 +0800
committerjkh <jkh@FreeBSD.org>1994-09-28 22:19:30 +0800
commitd08f7ab673a23dfc721b78f5b35e45c3f7b757f3 (patch)
tree4590f620b17acbc5c0c8ad1604e9d7e84a0fb068 /Mk
parent059486f7ebdb4ae7caa3827319663b9ae7d04778 (diff)
downloadfreebsd-ports-gnome-d08f7ab673a23dfc721b78f5b35e45c3f7b757f3.tar.gz
freebsd-ports-gnome-d08f7ab673a23dfc721b78f5b35e45c3f7b757f3.tar.zst
freebsd-ports-gnome-d08f7ab673a23dfc721b78f5b35e45c3f7b757f3.zip
Don't hardcode patch and its arguments. Not quite the same patch as submitted
by Robert Withrow, but he prodded me into thinking about it again. Thanks, Rob.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index f3afcdf783af..afccd3298284 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.39 1994/09/19 01:08:35 jkh Exp $
+# $Id: bsd.port.mk,v 1.40 1994/09/22 07:45:30 swallace Exp $
#
# Please view me with 4 column tabs!
@@ -115,6 +115,10 @@ MAKEFILE?= Makefile
NCFTP?= ncftp
NCFTPFLAGS?= -N
+PATCH?= patch
+PATCH_STRIP?= -p0
+PATCH_ARGS?= -d ${WRKSRC} --quiet -E ${PATCH_STRIP}
+
EXTRACT_CMD?= tar
EXTRACT_SUFX?= .tar.gz
EXTRACT_ARGS?= -C ${WRKDIR} -xzf
@@ -245,7 +249,7 @@ ${CONFIGURE_COOKIE}:
@if [ -d ${PATCHDIR} ]; then \
echo "===> Applying patches for ${DISTNAME}" ; \
for i in ${PATCHDIR}/patch-*; do \
- patch -d ${WRKSRC} --quiet -E -p0 < $$i; \
+ ${PATCH} ${PATCH_ARGS} < $$i; \
done; \
fi
# We have a small convention for our local configure scripts, which