aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2015-04-27 18:28:00 +0800
committerashish <ashish@FreeBSD.org>2015-04-27 18:28:00 +0800
commitd63d9c1d054a702d22635c31e8bf6b396fe0b64c (patch)
tree051d603e0bed60bcd0d916f1ebb0ad78600d2b2f /Mk
parentd2952c0873bb12fb20e3c5ef57fc75b7d7f110a6 (diff)
downloadfreebsd-ports-gnome-d63d9c1d054a702d22635c31e8bf6b396fe0b64c.tar.gz
freebsd-ports-gnome-d63d9c1d054a702d22635c31e8bf6b396fe0b64c.tar.zst
freebsd-ports-gnome-d63d9c1d054a702d22635c31e8bf6b396fe0b64c.zip
GNU Emacs Updates
editors/emacs: - Update to 24.5 - Remove dependency on GCC for i386 platform, if the bug is fixed in the version in use - Remove upstreamed diff editors/emacs-devel: - Update to git snapshot def0df01 - Remove git revision from PORTVERSION, rather encode it in DISTNAME - Remove dependency on GCC for i386 platform, if the bug is fixed in the version in use - Fix portlint warnings Mk/bsd.emacs.mk: - Update version number for editors/emacs - Remove deprecated block for emacs23 PR: 199553
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.emacs.mk23
1 files changed, 3 insertions, 20 deletions
diff --git a/Mk/bsd.emacs.mk b/Mk/bsd.emacs.mk
index 0288b1f59b7b..543fbeda2280 100644
--- a/Mk/bsd.emacs.mk
+++ b/Mk/bsd.emacs.mk
@@ -63,27 +63,10 @@ EMACS_PORT_NAME?= emacs24
EMACS_MASTERDIR_PKGFILES?= NO
-# Emacs-23.x
-.if (${EMACS_PORT_NAME} == "emacs23")
-EMACS_NAME= emacs
-EMACS_VER= 23.4
-EMACS_MAJOR_VER= 23
-EMACS_LIBDIR?= share/${EMACS_NAME}
-EMACS_LIBDIR_WITH_VER?= share/${EMACS_NAME}/${EMACS_VER}
-EMACS_PORTSDIR= ${PORTSDIR}/editors/emacs
-EMACS_COMMON_PORT= NO
-EMACS_HAS_MULE= YES
-EMACS_NO_SUBDIRSEL= NO
-.if (${EMACS_MASTERDIR_PKGFILES} == "YES")
-COMMENTFILE?= ${PKGDIR}/pkg-comment.${EMACS_PORT_NAME}
-DESCR?= ${PKGDIR}/pkg-descr.${EMACS_PORT_NAME}
-PLIST?= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
-.endif
-
# Emacs-24.x
-.elif (${EMACS_PORT_NAME} == "emacs24")
+.if (${EMACS_PORT_NAME} == "emacs24")
EMACS_NAME= emacs
-EMACS_VER= 24.4
+EMACS_VER= 24.5
EMACS_MAJOR_VER= 24
EMACS_LIBDIR?= share/${EMACS_NAME}
EMACS_LIBDIR_WITH_VER?= share/${EMACS_NAME}/${EMACS_VER}
@@ -118,7 +101,7 @@ PLIST?= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
check-makevars::
@${ECHO} "Makefile error: Bad value of EMACS_PORT_NAME: ${EMACS_PORT_NAME}."
@${ECHO} "Valid values are:"
- @${ECHO} " Emacs family: emacs23 emacs24 emacs-devel"
+ @${ECHO} " Emacs family: emacs24 emacs-devel"
@${FALSE}
.endif