aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-08-21 23:04:03 +0800
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-08-21 23:04:03 +0800
commitd64571e36cec4229ff9ba1daade6af00e2a32ae1 (patch)
tree688a1a59e294fbd5f6d4dd1e57e51dabb5e5a603 /Mk
parent17087d3bd773afeb5c21b4b81850ff276db59cc3 (diff)
downloadfreebsd-ports-gnome-d64571e36cec4229ff9ba1daade6af00e2a32ae1.tar.gz
freebsd-ports-gnome-d64571e36cec4229ff9ba1daade6af00e2a32ae1.tar.zst
freebsd-ports-gnome-d64571e36cec4229ff9ba1daade6af00e2a32ae1.zip
Simplify the whole configuration script business quite a bit. What
was I thinking before.. Submitted by: jkh
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 5 insertions, 9 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 94ac2fbe6317..1f16b846c801 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id$
+# $Id: bsd.port.mk,v 1.3 1994/08/21 14:32:40 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -18,8 +18,8 @@
# PKGDIR - Package creation files.
#
# USE_GMAKE - Says that the package uses gmake (*).
-# GNU_CONFIGURE - Says that the package uses GNU configure (*).
-# GNU_CONFIGURE_ARGS - If defined, override defaults with these args (*).
+# HAS_CONFIGURE - Says that the package has its own configure script (*).
+# CONFIGURE_ARGS - Pass these args to configure, if $HAS_CONFIGURE.
# HOME_LOCATION - site/path name (or user's email address) describing
# where this package came from or can be obtained if the
# tarball is missing.
@@ -103,12 +103,8 @@ configure: extract
patch -d ${WRKSRC} --quiet -E -p0 < $$i; \
done; \
fi
-.if defined(GNU_CONFIGURE)
-.if !defined(GNU_CONFIGURE_ARGS)
- @(cd ${WRKSRC}; ./configure i386--freebsd)
-.else !defined(GNU_CONFIGURE_ARGS)
- @(cd ${WRKSRC}; ./configure ${GNU_CONFIGURE_ARGS})
-.endif
+.if defined(HAS_CONFIGURE)
+ @(cd ${WRKSRC}; ./configure ${CONFIGURE_ARGS})
.endif
# We have a small convention for our local configure scripts, which
# is that ${.CURDIR} and the package working directory get passed as