aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-11-28 06:02:29 +0800
committerJan Beich <jbeich@FreeBSD.org>2017-11-28 06:02:29 +0800
commitd65b2886b1b3b2135f0b8982de4d9754517acf61 (patch)
tree3d66af70b6fe803c5deca7c6f3517c47fc018d8b /Mk
parent24f8089a52fd4b788c7355a9ffa66081d6b89c8b (diff)
downloadfreebsd-ports-gnome-d65b2886b1b3b2135f0b8982de4d9754517acf61.tar.gz
freebsd-ports-gnome-d65b2886b1b3b2135f0b8982de4d9754517acf61.tar.zst
freebsd-ports-gnome-d65b2886b1b3b2135f0b8982de4d9754517acf61.zip
lang/rust: avoid LLVM targeting SSE2 on i386 by default
This may help ports like textproc/ripgrep to run on old hardware. Rust itself still requires SSE2 until bootstrap is regenerated. PR: 223415 Approved by: rust (dumbbell)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 934a49eb8ee0..e4ded78f43de 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -395,7 +395,7 @@ MOZ_OPTIONS+= --enable-debug --disable-release
STRIP= # ports/184285
.else
MOZ_OPTIONS+= --disable-debug --disable-debug-symbols --enable-release
-. if ${MOZILLA_VER:R:R} >= 56
+. if ${MOZILLA_VER:R:R} >= 56 && (${MACHINE_CPU:Msse2} || ${ARCH:Maarch64})
MOZ_OPTIONS+= --enable-rust-simd
. endif
.endif