aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-01-10 05:12:53 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-01-10 05:12:53 +0800
commitd7fe2fff7b41e0ad19890526bfb37a3d178da65d (patch)
tree859ede6227eac8f07f0653c7f226a60978b8a354 /Mk
parent199e51b89380871fe7ab9043e5d1941cee28f834 (diff)
downloadfreebsd-ports-gnome-d7fe2fff7b41e0ad19890526bfb37a3d178da65d.tar.gz
freebsd-ports-gnome-d7fe2fff7b41e0ad19890526bfb37a3d178da65d.tar.zst
freebsd-ports-gnome-d7fe2fff7b41e0ad19890526bfb37a3d178da65d.zip
Add 'post-plist' target which can be hooked into to modify the plist without
needing to add more targets to STAGE_SEQ. This is especially useful for customizing the ports tree/framework without modifying bsd.port.mk. With hat: portmgr Discussed with: mat
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 4c9b70a9b4eb..0248fc5d8b50 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5912,6 +5912,7 @@ _BUILD_SEQ= build-message pre-build pre-build-script do-build \
_STAGE_DEP= build
_STAGE_SEQ= stage-message stage-dir run-depends lib-depends apply-slist pre-install generate-plist \
pre-su-install
+# post-plist must be after anything that modifies TMPPLIST
.if defined(NEED_ROOT)
_STAGE_SUSEQ= create-users-groups do-install \
kmod-post-install fix-perl-things \
@@ -5920,7 +5921,7 @@ _STAGE_SUSEQ= create-users-groups do-install \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist
+ move-uniquefiles-plist post-plist
.if defined(DEVELOPER)
_STAGE_SUSEQ+= stage-qa
.endif
@@ -5932,7 +5933,7 @@ _STAGE_SEQ+= create-users-groups do-install \
install-rc-script install-ldconfig-file install-license \
install-desktop-entries add-plist-info add-plist-docs \
add-plist-examples add-plist-data add-plist-post \
- move-uniquefiles-plist
+ move-uniquefiles-plist post-plist
.if defined(DEVELOPER)
_STAGE_SEQ+= stage-qa
.endif