aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-31 18:00:20 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-05-31 18:00:20 +0800
commitd8cff3e56b7f1643862133f4ce38dc516f62538b (patch)
tree24f5a9e916ed070890d7d4919c8341a505a53d3b /Mk
parentfd68fbf5c0053862a60f5058ab2af059acae2755 (diff)
downloadfreebsd-ports-gnome-d8cff3e56b7f1643862133f4ce38dc516f62538b.tar.gz
freebsd-ports-gnome-d8cff3e56b7f1643862133f4ce38dc516f62538b.tar.zst
freebsd-ports-gnome-d8cff3e56b7f1643862133f4ce38dc516f62538b.zip
Introduce PY_TYPING and simplify Makefile
Since devel/py-promise requires 3.6.4+, the minimal version is set to 3.6.4. With hat: python
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index e7724b7bac55..346ea1173741 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -659,6 +659,12 @@ PYGAME= ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game@${PY_FLAVOR}
PYNUMPY= ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR}
# Common Python modules that can be needed but only for some versions of Python.
+.if ${PYTHON_REL} < 3500
+PY_TYPING= ${PYTHON_PKGNAMEPREFIX}typing>=3.6.4:devel/py-typing@${PY_FLAVOR}
+.else
+PY_TYPING=
+.endif
+
.if ${PYTHON_REL} < 3400
PY_ENUM34= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34@${PY_FLAVOR}
PY_ENUM_COMPAT= ${PYTHON_PKGNAMEPREFIX}enum-compat>0:devel/py-enum-compat@${PY_FLAVOR}