aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-12-19 18:49:09 +0800
committerjbeich <jbeich@FreeBSD.org>2015-12-19 18:49:09 +0800
commitde51f86e4424882877000f8c30a034b77807bf54 (patch)
tree442e1d80ae3d907d98e5074c9d25b8557f6bb19b /Mk
parent74f92aeb2e2510877a674bafbb6fe9abd758b868 (diff)
downloadfreebsd-ports-gnome-de51f86e4424882877000f8c30a034b77807bf54.tar.gz
freebsd-ports-gnome-de51f86e4424882877000f8c30a034b77807bf54.tar.zst
freebsd-ports-gnome-de51f86e4424882877000f8c30a034b77807bf54.zip
www/firefox: update to 43.0.1
Changes: https://www.mozilla.org/en-US/firefox/43.0/releasenotes/ PR: 205357 Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net> Security: 2c2d1c39-1396-459a-91f5-ca03ee7c64c6 MFH: 2015Q4
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk4
-rw-r--r--Mk/bsd.gecko.mk6
2 files changed, 5 insertions, 5 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index d9e8fc98a137..b5b0076033d8 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -37,12 +37,12 @@ RUN_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
.elif ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 38
-_GECKO_VERSIONS= 38 42
+_GECKO_VERSIONS= 38 43
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-42_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+43_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 4f627410c481..73b3415cb859 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -129,8 +129,8 @@ CPPFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -Wl,-rpath,${PREFIX}/lib/${MOZILLA}
.if ${OPSYS} != DragonFly # XXX xpcshell crash during install
-# use jemalloc 3.0.0 API for stats/tuning
-MOZ_EXPORT+= MOZ_JEMALLOC3=1
+# use jemalloc 3.0.0 (4.0 for firefox 43+) API for stats/tuning
+MOZ_EXPORT+= MOZ_JEMALLOC3=1 MOZ_JEMALLOC4=1
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100079
. if ${MOZILLA_VER:R:R} < 43
# system jemalloc 4.0.0 vs. bundled jemalloc 3.6.0-204-gb4acf73
@@ -574,7 +574,7 @@ gecko-post-patch:
${MOZSRC}/xpcom/io/nsAppFileLocationProvider.cpp \
${MOZSRC}/toolkit/xre/nsXREDirProvider.cpp
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${MOZSRC}/extensions/spellcheck/hunspell/src/mozHunspell.cpp
+ ${MOZSRC}/extensions/spellcheck/hunspell/*/mozHunspell.cpp
# handles mozilla pis scripts.
gecko-moz-pis-patch: