aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2015-08-09 16:06:43 +0800
committeracm <acm@FreeBSD.org>2015-08-09 16:06:43 +0800
commite08c72b4818dedf918c6fe30621cb5bc7c960f1d (patch)
treedcd9771851d8a5b000509363eeaba5add2d5d4de /Mk
parent5784aae1aaa23ea9554d64016e10f1a870feefdf (diff)
downloadfreebsd-ports-gnome-e08c72b4818dedf918c6fe30621cb5bc7c960f1d.tar.gz
freebsd-ports-gnome-e08c72b4818dedf918c6fe30621cb5bc7c960f1d.tar.zst
freebsd-ports-gnome-e08c72b4818dedf918c6fe30621cb5bc7c960f1d.zip
- editors/lazarus update to 1.4.2
- Add USE_FPC_RUN to bsd.fpc.mk. It add fpc units like run dependencies. Otherwise fpc units only are added like build dependencies (less dependencies registered when they are installed with pkg). - Remove GTK1 obsolete dependencies - Bump all ports with dependencies of fpc-* units - Bump all ports with dependencies of lazarus ports - Clean up
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.fpc.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.fpc.mk b/Mk/bsd.fpc.mk
index be66a523890b..150df0b7395d 100644
--- a/Mk/bsd.fpc.mk
+++ b/Mk/bsd.fpc.mk
@@ -13,6 +13,9 @@
# free pascal compiler, if you need install additional fpc
# units, they can be listed there (USE_FPC= gtk x11 opengl).
#
+# USE_FPC_RUN - If you set this to "yes", free pascal units will be
+# registered also as run dependencies.
+#
# WANT_FPC_BASE - If you set this to "yes", this automatically will install
# all base units of fpc (gdbint graph ibase libasync hash
# httpd mysql netdb odbc oracle pasjpeg paszlib pthreads
@@ -197,10 +200,14 @@ zlib_UNIT= devel/fpc-zlib
. if ${_FPC_ALL_UNITS:M${UNITS}}!=""
. if ${_FPC_CFG_UNITS:M${UNITS}}!=""
BUILD_DEPENDS+= ${UNITSDIR}/${UNITS}/fpunits.cfg:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. if defined(USE_FPC_RUN)
RUN_DEPENDS+= ${UNITSDIR}/${UNITS}/fpunits.cfg:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. endif
. else
BUILD_DEPENDS+= ${UNITSDIR}/${UNITS}/Package.fpc:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. if defined(USE_FPC_RUN)
RUN_DEPENDS+= ${UNITSDIR}/${UNITS}/Package.fpc:${PORTSDIR}/${${UNITS:S/-/_/}_UNIT}
+. endif
. endif
security-check: fpc-check-install