aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-10-09 13:52:45 +0800
committerbapt <bapt@FreeBSD.org>2013-10-09 13:52:45 +0800
commite1c1e3428c0dc997fd2fd086e6e9d5c52444234f (patch)
tree7b7b658d8c4e2ce51abd94327424071166e585aa /Mk
parentc1a94c8517fdcd7a01ab60a778ebcc6c5f288c53 (diff)
downloadfreebsd-ports-gnome-e1c1e3428c0dc997fd2fd086e6e9d5c52444234f.tar.gz
freebsd-ports-gnome-e1c1e3428c0dc997fd2fd086e6e9d5c52444234f.tar.zst
freebsd-ports-gnome-e1c1e3428c0dc997fd2fd086e6e9d5c52444234f.zip
Add a new argument openmp to make sure that only gcc is used (for now) is the port requires openmp
Requested by: brooks
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/compiler.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/Uses/compiler.mk b/Mk/Uses/compiler.mk
index fa9cf8d028b9..52b016be0e88 100644
--- a/Mk/Uses/compiler.mk
+++ b/Mk/Uses/compiler.mk
@@ -11,6 +11,7 @@
# c++11-lang: The port need a compiler understanding C++11
# c++11-lib: The port need a compiler understanding C++11 and with a C++11 ready standard library
# c11: The port need a compiler understanding c11
+# openmp: The port need a compiler understanding openmp
# features: The port will determine the features supported by the default compiler
#
# Variable to test after <bsd.port.pre.mk>
@@ -39,6 +40,8 @@ _COMPILER_ARGS+= features c11
_COMPILER_ARGS+= features
.elif ${compiler_ARGS} == env
_COMPILER_ARGS+= env
+.elif ${compiler_ARGS} == openmp
+_COMPILER_ARGS+= env openmp
.else
IGNORE= Invalid argument "${compiler_ARGS}", valid arguments are: ${VALID_ARGS}
_COMPILER_ARGS= #
@@ -56,6 +59,12 @@ COMPILER_TYPE= clang
COMPILER_TYPE= gcc
.endif
+.if ${_COMPILER_ARGS:Mopenmp}
+.if ${COMPILER_TYPE} == clang
+USE_GCC= any
+.endif
+.endif
+
.if ${_COMPILER_ARGS:Mfeatures}
_CXXINTERNAL!= ${CXX} -\#\#\# /dev/null 2>&1
.if ${_CXXINTERNAL:M\"-lc++\"}