aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2014-02-25 08:32:09 +0800
committergerald <gerald@FreeBSD.org>2014-02-25 08:32:09 +0800
commite1e6a5d3c05429d77b3e1e8c87cd1197545c3907 (patch)
treea5865baf84701382bcd97846b34af457c62a4928 /Mk
parent966fd7f625c909f2f2e61d787d6c67f113cb52d3 (diff)
downloadfreebsd-ports-gnome-e1e6a5d3c05429d77b3e1e8c87cd1197545c3907.tar.gz
freebsd-ports-gnome-e1e6a5d3c05429d77b3e1e8c87cd1197545c3907.tar.zst
freebsd-ports-gnome-e1e6a5d3c05429d77b3e1e8c87cd1197545c3907.zip
Reword the documentation at the top of this file.
Sort the FPC_DEFAULT and GCC_DEFAULT entries.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/fortran.mk2
-rw-r--r--Mk/bsd.default-versions.mk11
-rw-r--r--Mk/bsd.gcc.mk2
3 files changed, 8 insertions, 7 deletions
diff --git a/Mk/Uses/fortran.mk b/Mk/Uses/fortran.mk
index 579bec0182cb..64617f5e5d16 100644
--- a/Mk/Uses/fortran.mk
+++ b/Mk/Uses/fortran.mk
@@ -16,7 +16,7 @@ fortran_ARGS= gcc
.endif
.if ${fortran_ARGS} == gcc
-_GCC_VER= 46
+_GCC_VER= 47
BUILD_DEPENDS+= gfortran${_GCC_VER}:${PORTSDIR}/lang/gcc
RUN_DEPENDS+= gfortran${_GCC_VER}:${PORTSDIR}/lang/gcc
USE_BINUTILS= yes
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index f41438ea8928..7885423f2032 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -2,12 +2,13 @@
#
# MAINTAINER: ports@FreeBSD.org
#
-# Handle the default versions for users chosable multi versions.
+# Provide default versions for ports with multiple versions selectable
+# by the user.
#
-# It expects users to define DEFAULT_VERSIONS in their make.conf
-# Syntax is the following:
+# Users who want to override these defaults can easily do so by defining
+# DEFAULT_VERSIONS in their make.conf as follows:
#
-# DEFAULT_VERSIONS= perl5=5.18 ruby=2.0
+# DEFAULT_VERSIONS= perl5=5.18 ruby=2.0
.if !defined(_INCLUDE_BSD_DEFAULT_VERSIONS_MK)
_INCLUDE_BSD_DEFAULT_VERSIONS_MK= yes
@@ -18,8 +19,8 @@ ${_l:U}_DEFAULT= ${lang:C/.*=//g}
.endfor
APACHE_DEFAULT?= 2.2
-GCC_DEFAULT?= 4.6
FPC_DEFAULT?= 2.6.2
+GCC_DEFAULT?= 4.6
LUA_DEFAULT?= 5.2
MYSQL_DEFAULT?= 5.5
PERL5_DEFAULT?= 5.16
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index f8e535b017af..cc158ea5be70 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -19,7 +19,7 @@
#
# Examples:
# USE_GCC= yes # port requires a current version of GCC
-# # (4.6 as of today, subject to change).
+# # (4.7 as of today, subject to change).
# USE_GCC= any # port requires GCC 4.2 or later.
# USE_GCC= 4.8+ # port requires GCC 4.8 or later.
# USE_GCC= 4.8 # port requires GCC 4.8.