aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-23 20:33:13 +0800
committermarino <marino@FreeBSD.org>2016-08-23 20:33:13 +0800
commite260bf54084767677f9fcd50b4d766fa6c77913c (patch)
treeac81945c77247fe98d1072dac54ebc09c9b2a5e6 /Mk
parent3f8e3d61a03d4519006b1d79e4e6bfe2bc5c2c10 (diff)
downloadfreebsd-ports-gnome-e260bf54084767677f9fcd50b4d766fa6c77913c.tar.gz
freebsd-ports-gnome-e260bf54084767677f9fcd50b4d766fa6c77913c.tar.zst
freebsd-ports-gnome-e260bf54084767677f9fcd50b4d766fa6c77913c.zip
Mk/Uses/alias.mk: Fix typo, remove "8" option
The "8" refers to FreeBSD 8.x which is no longer supported by the ports tree. It's never been used (to my knowledge) so just remove the option altogether.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/alias.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/Mk/Uses/alias.mk b/Mk/Uses/alias.mk
index e581ad8557f4..23e6a575d515 100644
--- a/Mk/Uses/alias.mk
+++ b/Mk/Uses/alias.mk
@@ -1,12 +1,12 @@
# $FreeBSD$
#
-# Add __FreeSBD__ definition to CFLAGS
+# Add __FreeBSD__ definition to CFLAGS
# Used by DPorts when masquerading as FreeBSD allows port to build without
# additional patches
#
# Feature: alias
# Usage: USES=alias or USES=alias:ARGS
-# Valid ARGS: 8, 9 (default), 10, 11
+# Valid ARGS: 9 (default), 10, 11
#
# MAINTAINER: marino@FreeBSD.org
@@ -18,8 +18,7 @@ _INCLUDE_USES_ALIAS_MK= yes
.if empty(alias_ARGS)
CFLAGS+= -D__FreeBSD__=9
.else
-. if ${alias_ARGS} == 8 || ${alias_ARGS} == 10 \
- || ${alias_ARGS} == 9 || ${alias_ARGS} == 11
+. if ${alias_ARGS} == 9 || ${alias_ARGS} == 10 || ${alias_ARGS} == 11
CFLAGS+= -D__FreeBSD__=${alias_ARGS}
. else
IGNORE= invalid MAJOR RELEASE argument (${alias_ARGS}) for USES=alias