aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 15:41:13 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-10 15:41:13 +0800
commite3b01a75e8f98cca678c8ca66f7c1dc64a26c479 (patch)
tree755f9c5638e05fb54d9a1987e36ddfb7a734f616 /Mk
parentb8b1394bdd5942b22e5067a124041a471ecd599b (diff)
downloadfreebsd-ports-gnome-e3b01a75e8f98cca678c8ca66f7c1dc64a26c479.tar.gz
freebsd-ports-gnome-e3b01a75e8f98cca678c8ca66f7c1dc64a26c479.tar.zst
freebsd-ports-gnome-e3b01a75e8f98cca678c8ca66f7c1dc64a26c479.zip
Remove USE_MOTIF as it is not used anymore
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk22
1 files changed, 1 insertions, 21 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 325ab7bc0019..e56a67bd4480 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -352,13 +352,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Supported components are: glut, glu, glw, and gl.
# If set to "yes", this is equivalent to "glu". Note that
# glew and glut depend on glu, glw and glu depend on gl.
-# USE_MOTIF - If set, this port uses a Motif toolkit. Implies USE_XORG+= xpm
-# NO_OPENMOTIF - If set, this port uses a custom Motif toolkit
-# instead of Openmotif.
-# Used only when USE_MOTIF is set.
-# WANT_LESSTIF - If set, this port uses Lesstif as Motif toolkit.
-# Used only when USE_MOTIF is set. Implies
-# NO_OPENMOTIF.
##
# USE_SDL - If set, this port uses the sdl libraries.
# See bsd.sdl.mk for more information.
@@ -1888,17 +1881,6 @@ IGNORE= cannot be built: there is no emulators/linux_base-${USE_LINUX}, perhaps
RUN_DEPENDS+= ${LINUX_BASE_PORT}
.endif
-.if defined(USE_MOTIF)
-USE_XORG+= xpm
-.if defined(WANT_LESSTIF)
-LIB_DEPENDS+= Xm:${PORTSDIR}/x11-toolkits/lesstif
-NO_OPENMOTIF= yes
-.endif
-.if !defined(NO_OPENMOTIF)
-LIB_DEPENDS+= Xm.4:${PORTSDIR}/x11-toolkits/open-motif
-.endif
-.endif
-
.if defined(USE_DISPLAY) && !defined(DISPLAY)
BUILD_DEPENDS+= Xvfb:${PORTSDIR}/x11-servers/xorg-vfbserver \
${LOCALBASE}/lib/X11/fonts/misc/8x13O.pcf.gz:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps \
@@ -2137,7 +2119,7 @@ MAKE_FLAGS?= -f
MAKEFILE?= Makefile
MAKE_ENV+= PREFIX=${PREFIX} \
LOCALBASE=${LOCALBASE} \
- MOTIFLIB="${MOTIFLIB}" LIBDIR="${LIBDIR}" \
+ LIBDIR="${LIBDIR}" \
CC="${CC}" CFLAGS="${CFLAGS}" \
CPP="${CPP}" CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
@@ -2393,8 +2375,6 @@ PKG_SUFX?= .tbz
# where pkg_add records its dirty deeds.
PKG_DBDIR?= /var/db/pkg
-MOTIFLIB?= -L${LOCALBASE}/lib -lXm -lXp
-
ALL_TARGET?= all
INSTALL_TARGET?= install
INSTALL_TARGET+= ${LATE_INSTALL_ARGS}