aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-29 21:31:35 +0800
committermat <mat@FreeBSD.org>2016-06-29 21:31:35 +0800
commite56c95fc56fc635e0733547ad6cf78a49a3efc75 (patch)
treeb3191af0aaeeaae130e111a2cd138224d0584f8a /Mk
parent5b511280671a62e6bd6c24ee1494ec3c8ebd28f8 (diff)
downloadfreebsd-ports-gnome-e56c95fc56fc635e0733547ad6cf78a49a3efc75.tar.gz
freebsd-ports-gnome-e56c95fc56fc635e0733547ad6cf78a49a3efc75.tar.zst
freebsd-ports-gnome-e56c95fc56fc635e0733547ad6cf78a49a3efc75.zip
For some reason, != "" and == "" don't work the same with make and
fmake, but, empty does. Pointy hat to: mat, or make(1) pick one. Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/php.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index aab7bb21cf75..32b450586729 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -377,8 +377,8 @@ zlib_DEPENDS= archivers/php${PHP_VER}-zlib
. for extension in ${USE_PHP}
ext= ${extension}
-. if ${_USE_PHP_VER${PHP_VER}:M${ext:S/:build//}} != ""
-. if ${PHP_EXT_INC:M${extension:S/:build//}} == ""
+. if !empty(_USE_PHP_VER${PHP_VER}:M${extension:S/:build//})
+. if empty(PHP_EXT_INC:M${extension:S/:build//})
. if !empty(php_ARGS:Mbuild) || !empty(ext:M*\:build)
BUILD_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/${extension:S/:build//}.so:${${extension:S/:build//}_DEPENDS}
. endif