aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-06-28 20:20:03 +0800
committersobomax <sobomax@FreeBSD.org>2002-06-28 20:20:03 +0800
commite587f96e2272bc6af6d664e0eee6b30edf13c3e1 (patch)
treeec27d52509c79eda88dd324283bf9cb0e8906a0c /Mk
parent0556dbbd37bdf7125bb7201d08b48432d7c076be (diff)
downloadfreebsd-ports-gnome-e587f96e2272bc6af6d664e0eee6b30edf13c3e1.tar.gz
freebsd-ports-gnome-e587f96e2272bc6af6d664e0eee6b30edf13c3e1.tar.zst
freebsd-ports-gnome-e587f96e2272bc6af6d664e0eee6b30edf13c3e1.zip
Use system sed(1) for doing in-place editing if OSVERSION is greater than
460100. Submitted by: obrien
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8a7a389acbdf..2ba61643b274 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -712,7 +712,7 @@ PKGDIR?= ${MASTERDIR}
# Special macro for doing in-place file editing using regexps
.if defined(USE_REINPLACE)
REINPLACE_ARGS?= -i.bak
-.if ${OSVERSION} <= 500033
+.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500034 )
BUILD_DEPENDS+= ${LOCALBASE}/bin/sed_inplace:${PORTSDIR}/textproc/sed_inplace
REINPLACE_CMD?= ${LOCALBASE}/bin/sed_inplace ${REINPLACE_ARGS}
.else