aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-14 18:11:19 +0800
committerbapt <bapt@FreeBSD.org>2013-03-14 18:11:19 +0800
commite78f7fb401fd5c8eb6d306a74ecf52068c56160d (patch)
tree24a0c14a0913d29f7a5b5f8475bb9c240cd75e41 /Mk
parente3100f579808b8e1d1db90beb8bd675d28e9477f (diff)
downloadfreebsd-ports-gnome-e78f7fb401fd5c8eb6d306a74ecf52068c56160d.tar.gz
freebsd-ports-gnome-e78f7fb401fd5c8eb6d306a74ecf52068c56160d.tar.zst
freebsd-ports-gnome-e78f7fb401fd5c8eb6d306a74ecf52068c56160d.zip
Fix info files with pkgng.
This bring the first Keyword into the ports tree. Keywords are pkgng custom plist keyword definition. info.yaml defines a new @info keyword usable only with pkgng which will: - add the info agument to the file list - set a post-installation execution script - set a post-deinstallation execution script in keyword definition the script uses the same format (%f, %F, %D, ...) as @exec/@unexec does it just add a new one: %@ which correspond the the keyword argument line. Exp-run: miwi
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c0af684b0b8b..ffe6872b4eb9 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5813,11 +5813,15 @@ add-plist-info:
.if defined(INFO)
.for i in ${INFO}
install-info --quiet ${PREFIX}/${INFO_PATH}/$i.info ${PREFIX}/${INFO_PATH}/dir
+.if !defined(WITH_PKGNG)
@${ECHO_CMD} "@unexec install-info --quiet --delete %D/${INFO_PATH}/$i.info %D/${INFO_PATH}/dir" \
>> ${TMPPLIST}
@${LS} ${PREFIX}/${INFO_PATH}/$i.info* | ${SED} -e s:${PREFIX}/::g >> ${TMPPLIST}
@${ECHO_CMD} "@exec install-info --quiet %D/${INFO_PATH}/$i.info %D/${INFO_PATH}/dir" \
>> ${TMPPLIST}
+.else
+ @${LS} ${PREFIX}/${INFO_PATH}/$i.info* | ${SED} -e s:${PREFIX}/:@info\ :g >> ${TMPPLIST}
+.endif
.endfor
.if defined(INFO_SUBDIR)
@${ECHO_CMD} "@unexec ${RMDIR} %D/${INFO_PATH}/${INFO_SUBDIR} 2> /dev/null || true" >> ${TMPPLIST}