aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-29 01:16:03 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-29 01:16:03 +0800
commitede8664aef7fd44658493a91e2ba15fae197bdab (patch)
tree3d43e7a9ab3bd928069e891f346fa11524c38f0d /Mk
parent8340ffa8112cab5d2b865f291e67ec6606ac53e7 (diff)
downloadfreebsd-ports-gnome-ede8664aef7fd44658493a91e2ba15fae197bdab.tar.gz
freebsd-ports-gnome-ede8664aef7fd44658493a91e2ba15fae197bdab.tar.zst
freebsd-ports-gnome-ede8664aef7fd44658493a91e2ba15fae197bdab.zip
Fix sed command in proxydeps_suggest_uses qa.sh check
It led to incorrect "you need USE_XORG+" suggestion Submitted by: amdmi3 Approved by: portmgr (bapt) Differential Revision: D6618
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/qa.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Scripts/qa.sh b/Mk/Scripts/qa.sh
index 19dc5795f148..11ba6a8313d4 100644
--- a/Mk/Scripts/qa.sh
+++ b/Mk/Scripts/qa.sh
@@ -449,7 +449,7 @@ proxydeps_suggest_uses() {
warn "you need USE_GL+=glut"
# Xorg-libraries: this should be by XORG_MODULES @ bsd.xorg.mk
elif echo ${pkg} | grep -E '/lib(X11|Xau|Xdmcp|Xext|SM|ICE|Xfixes|Xft|Xdamage|Xcomposite|Xcursor|Xinerama|Xmu|Xmuu|Xpm|Xt|Xtst|Xi|Xrandr|Xrender|Xres|XScrnSaver|Xv|Xxf86vm|Xxf86dga|Xxf86misc|xcb)$' > /dev/null; then
- warn "you need USE_XORG+=$(echo ${pkg} | sed -E 's|.*/lib//' | tr '[:upper:]' '[:lower:]')"
+ warn "you need USE_XORG+=$(echo ${pkg} | sed -E 's|.*/lib||' | tr '[:upper:]' '[:lower:]')"
elif [ ${pkg} = 'x11/pixman' ]; then
warn "you need USE_XORG+=pixman"
# Qt4