aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-31 22:27:31 +0800
committerPav Lucistnik <pav@FreeBSD.org>2006-12-31 22:27:31 +0800
commitf5ae70fdf6dc81d70bc7835eba11858478965d21 (patch)
treec1329b1e399f60c27d56b6a5e09fdf7b2ba64f9a /Mk
parent763c937157a55e9da11b74043ef05b27dec83f89 (diff)
downloadfreebsd-ports-gnome-f5ae70fdf6dc81d70bc7835eba11858478965d21.tar.gz
freebsd-ports-gnome-f5ae70fdf6dc81d70bc7835eba11858478965d21.tar.zst
freebsd-ports-gnome-f5ae70fdf6dc81d70bc7835eba11858478965d21.zip
- Re-add _WX_ILLEGAL_VERS_* handling removed in previous commit
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.wx.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index bfad54a89f1b..35d9e2904038 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -136,6 +136,14 @@ _WX_VERS_ALL= 2.4 2.6 2.8
_WX_VERS_UC_ALL= 2.6 2.8
_WX_VERS_LISTS= WANT_WX_VER WITH_WX_VER _WX_VER_INSTALLED
+# _WX_ILLEGAL_VERS_PYTHON - List of versions where wxPython is not available
+# _WX_ILLEGAL_VERS_MOZILLA - List of versions where wxmozilla is not available
+# _WX_ILLEGAL_VERS_SVG - List of versions where wxsvg is not available
+
+_WX_ILLEGAL_VERS_PYTHON= 2.8
+_WX_ILLEGAL_VERS_MOZILLA= 2.6 2.8
+_WX_ILLEGAL_VERS_SVG= 2.4 2.8
+
#
# Variables used to determine what is needed:
# _WX_PORT_comp_ver - Port directory.
@@ -417,6 +425,27 @@ _WX_UCL= #
_WX_PYSUFX= -ansi
.endif
+# Limit range of possible versions for python, svg and mozila
+
+.for comp in ${WX_COMPS}
+_WX_COMP= ${comp}
+. if ${_WX_COMP} == "python"
+. for excl in ${_WX_ILLEGAL_VERS_PYTHON}
+_WX_VER_FINAL:= ${_WX_VER_FINAL:S/${excl}//}
+. endfor
+. endif
+. if ${_WX_COMP} == "mozilla"
+. for excl in ${_WX_ILLEGAL_VERS_MOZILLA}
+_WX_VER_FINAL:= ${_WX_VER_FINAL:S/${excl}//}
+. endfor
+. endif
+. if ${_WX_COMP} == "svg"
+. for excl in ${_WX_ILLEGAL_VERS_SVG}
+_WX_VER_FINAL:= ${_WX_VER_FINAL:S/${excl}//}
+. endfor
+. endif
+.endfor
+
# Remove unusable installed versions.
.for ver in ${_WX_VER_INSTALLED}