aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-08-26 14:38:32 +0800
committerjbeich <jbeich@FreeBSD.org>2015-08-26 14:38:32 +0800
commitf5e960b642923548e67be95d72e95034b9835a61 (patch)
tree2326c0dcbe308c1ec8225b5c5da94be764aa4e34 /Mk
parent9d247abc8ff733f6d5ee18b5ec9240cb248d4411 (diff)
downloadfreebsd-ports-gnome-f5e960b642923548e67be95d72e95034b9835a61.tar.gz
freebsd-ports-gnome-f5e960b642923548e67be95d72e95034b9835a61.tar.zst
freebsd-ports-gnome-f5e960b642923548e67be95d72e95034b9835a61.zip
gecko: add INTEGER_SAMPLES option
arm use S16 samples and libtremor since Firefox 34. So, adjust dependencies and make it controllable (for testing on x86). Note, arm is still BROKEN until ports/202642. https://bugzilla.mozilla.org/show_bug.cgi?id=1047791
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index e1faba3c4ef3..50737b32ecf2 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -142,7 +142,14 @@ MOZ_OPTIONS+= --enable-jemalloc
.endif # !DragonFly
# Standard depends
-_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss opus png pixman soundtouch sqlite vorbis vpx
+_ALL_DEPENDS= cairo event ffi graphite harfbuzz hunspell icu jpeg nspr nss opus png pixman soundtouch sqlite vpx
+
+.if ${PORT_OPTIONS:MINTEGER_SAMPLES}
+MOZ_EXPORT+= MOZ_INTEGER_SAMPLES=1
+_ALL_DEPENDS+= tremor
+.else
+_ALL_DEPENDS+= vorbis
+.endif
.if ! ${PORT_OPTIONS:MBUNDLED_CAIRO}
cairo_LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo
@@ -209,6 +216,9 @@ sqlite_MOZ_OPTIONS= --enable-system-sqlite
theora_LIB_DEPENDS= libtheora.so:${PORTSDIR}/multimedia/libtheora
theora_MOZ_OPTIONS= --with-system-theora
+tremor_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+tremor_MOZ_OPTIONS= --with-system-tremor --with-system-ogg
+
vorbis_LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis
vorbis_MOZ_OPTIONS= --with-system-vorbis --with-system-ogg
.endif