aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-05-21 18:21:39 +0800
committerFlorent Thoumie <flz@FreeBSD.org>2007-05-21 18:21:39 +0800
commitf8e2a239acc2207c1addecc400221e51a8df0382 (patch)
tree925892d170ed0fad6a2700febb668707e805a209 /Mk
parentca0d7739437d8179095a364781dca0706918b154 (diff)
downloadfreebsd-ports-gnome-f8e2a239acc2207c1addecc400221e51a8df0382.tar.gz
freebsd-ports-gnome-f8e2a239acc2207c1addecc400221e51a8df0382.tar.zst
freebsd-ports-gnome-f8e2a239acc2207c1addecc400221e51a8df0382.zip
Fix USE_XLIB to depend on stub file rather than libX11.
Submitted by: marcus Approved by: portmgr (blanket)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 282111d5e669..756c6175b5f5 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2091,7 +2091,12 @@ USE_SUBMAKE= yes
. if defined(USE_LINUX)
RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-xorg-libs
. else
+. if ${X_WINDOW_SYSTEM:L} == xorg
+BUILD_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
+RUN_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
+. else
LIB_DEPENDS+= X11.6:${X_LIBRARIES_PORT}
+. endif
. endif
# Add explicit X options to avoid problems with false positives in configure
.if defined(GNU_CONFIGURE)