aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-01-10 07:28:19 +0800
committerFlorian Smeets <flo@FreeBSD.org>2013-01-10 07:28:19 +0800
commitfc9eea721229b0e204127b9da191eb0328b24ebc (patch)
tree6506ed591ae5bac1d34791c00b9064d73becc691 /Mk
parenta9fe9cfae6cb1729d393185f76fa602631e97bc4 (diff)
downloadfreebsd-ports-gnome-fc9eea721229b0e204127b9da191eb0328b24ebc.tar.gz
freebsd-ports-gnome-fc9eea721229b0e204127b9da191eb0328b24ebc.tar.zst
freebsd-ports-gnome-fc9eea721229b0e204127b9da191eb0328b24ebc.zip
- update firefox, thunderbird, linux-firefox and linux-thunderbird to 17.0.2
- update firefox-esr, thunderbird-esr and libxul to 10.0.12 - update linux-seamonkey to 2.15 Security: http://www.vuxml.org/freebsd/a4ed6632-5aa9-11e2-8fcb-c8600054b392.html
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk40
1 files changed, 27 insertions, 13 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 53d8a49a313d..46e59a7ebd49 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -441,7 +441,7 @@ Gecko_Pre_Include= bsd.gecko.mk
#
# Ports can use the following:
#
-# USE_MOZILLA By default, it enables the denendencies: cairo, dbm,
+# USE_MOZILLA By default, it enables the denendencies: cairo,
# event, ffi, hunspell, jpeg, nspr, nss, png, sqlite,
# vpx and zip. Search for '_ALL_DEPENDS' below to see
# the list. If your port doesn't need one of list then
@@ -554,10 +554,10 @@ LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
.if ${MOZILLA_VER:R:R} >= 16 || exists(${.CURDIR}/files/patch-bug788955)
.if ${OSVERSION} > 1000011
# use jemalloc 3.0.0 API in libc
-MOZ_EXPORT+= MOZ_JEMALLOC=1
+MOZ_EXPORT+= MOZ_JEMALLOC=1 MOZ_JEMALLOC3=1
.elif ${OSVERSION} > 701106
MOZ_OPTIONS+= --enable-jemalloc
-MOZ_EXPORT+= MOZ_JEMALLOC=1
+MOZ_EXPORT+= MOZ_JEMALLOC=1 MOZ_JEMALLOC3=1
.endif
.endif
@@ -568,14 +568,12 @@ MOZ_EXPORT+= ac_cv_thread_keyword=no \
.endif
# Standard depends
-_ALL_DEPENDS= cairo dbm event ffi hunspell jpeg nspr nss png sqlite vpx zip
+_ALL_DEPENDS= cairo event ffi hunspell jpeg nspr nss png sqlite vpx zip
cairo_LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
cairo_MOZ_OPTIONS= --enable-system-cairo --enable-system-pixman
cairo_EXTRACT_AFTER_ARGS= --exclude mozilla*/gfx/cairo
-dbm_EXTRACT_AFTER_ARGS= --exclude mozilla*/dbm
-
event_LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
event_MOZ_OPTIONS= --with-system-libevent
event_EXTRACT_AFTER_ARGS= --exclude mozilla*/ipc/chromium/src/third_party/libevent
@@ -598,7 +596,8 @@ nspr_MOZ_OPTIONS= --with-system-nspr
nss_LIB_DEPENDS= nss3:${PORTSDIR}/security/nss
nss_MOZ_OPTIONS= --with-system-nss
-nss_EXTRACT_AFTER_ARGS= --exclude mozilla*/security/coreconf \
+nss_EXTRACT_AFTER_ARGS= --exclude mozilla*/dbm \
+ --exclude mozilla*/security/coreconf \
--exclude mozilla*/security/nss
png_LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
@@ -607,6 +606,9 @@ png_EXTRACT_AFTER_ARGS= --exclude mozilla*/media/libpng
sqlite_LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
sqlite_MOZ_OPTIONS= --enable-system-sqlite
+.if ${MOZILLA_VER:R:R} >= 20 || exists(${.CURDIR}/files/patch-bug787804)
+sqlite_EXTRACT_AFTER_ARGS= --exclude mozilla*/db/sqlite3
+.endif
vpx_LIB_DEPENDS= vpx:${PORTSDIR}/multimedia/libvpx
vpx_MOZ_OPTIONS= --with-system-libvpx
@@ -663,12 +665,10 @@ MOZ_OPTIONS+= --with-system-zlib \
LIBS+= -Wl,--as-needed,-lcxxrt,--no-as-needed
.endif
-.if ${PORT_OPTIONS:MQT4}
-MOZ_TOOLKIT= cairo-qt
-USE_MOZILLA+= -cairo # ports/169343
-.endif
-
.if ${MOZ_TOOLKIT:Mcairo-qt}
+# don't use - transparent backgrounds (bug 521582),
+USE_MOZILLA+= -cairo # ports/169343
+USE_DISPLAY=yes # install
USE_GNOME+= pango
USE_QT4+= moc_build gui network opengl
MOZ_OPTIONS+= --with-qtdir= # pkg-config
@@ -735,6 +735,16 @@ MOZ_OPTIONS+= --enable-libproxy
MOZ_OPTIONS+= --disable-libproxy
.endif
+.if ${PORT_OPTIONS:MWEBRTC}
+BUILD_DEPENDS+= v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat
+LIB_DEPENDS+= v4l2:${PORTSDIR}/multimedia/libv4l
+. if ! ${PORT_OPTIONS:MALSA}
+IGNORE= WEBRTC works only with ALSA audio backend
+. endif
+.else
+MOZ_OPTIONS+= --disable-webrtc
+.endif
+
.if ${PORT_OPTIONS:MALSA}
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
@@ -842,13 +852,17 @@ gecko-post-patch:
${PATCH} ${PATCH_ARGS} -d ${MOZSRC}/nsprpub/build < $$i; \
done
@${REINPLACE_CMD} -e '/DLL_SUFFIX/s/so\.1$$/so/' \
- ${WRKSRC}/nsprpub/configure
+ ${MOZSRC}/nsprpub/configure
.endif
.if ${USE_MOZILLA:M-nss}
@${ECHO_MSG} "===> Applying NSS patches"
@for i in ${.CURDIR}/../../security/nss/files/patch-*; do \
${PATCH} ${PATCH_ARGS} -d ${MOZSRC}/security/nss < $$i; \
done
+ @${REINPLACE_CMD} -e '/DLL_SUFFIX/d' \
+ ${MOZSRC}/security/coreconf/FreeBSD.mk
+ @${REINPLACE_CMD} -e '/\.so/d' \
+ ${MOZSRC}/security/coreconf/rules.mk
.endif
.for subdir in "" nsprpub js/src
@if [ -f ${MOZSRC}/${subdir}/config/system-headers ] ; then \