aboutsummaryrefslogtreecommitdiffstats
path: root/Tools/scripts/bump-revision.sh
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-19 00:26:09 +0800
committermat <mat@FreeBSD.org>2014-11-19 00:26:09 +0800
commitc8487f0c3139deded81740f36be421b17160ecaa (patch)
tree47ba5ad3d8c0d2a93553de2b45a1ade08b94497f /Tools/scripts/bump-revision.sh
parent2e8e318bae4c1178b7235b58e846b5c4f4918fe5 (diff)
downloadfreebsd-ports-gnome-c8487f0c3139deded81740f36be421b17160ecaa.tar.gz
freebsd-ports-gnome-c8487f0c3139deded81740f36be421b17160ecaa.tar.zst
freebsd-ports-gnome-c8487f0c3139deded81740f36be421b17160ecaa.zip
Make this work with any amount of tabulations between the = and the value of PORTREVISION.
Sponsored by: Absolight
Diffstat (limited to 'Tools/scripts/bump-revision.sh')
-rwxr-xr-xTools/scripts/bump-revision.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tools/scripts/bump-revision.sh b/Tools/scripts/bump-revision.sh
index e16fa39393f4..84562458aaae 100755
--- a/Tools/scripts/bump-revision.sh
+++ b/Tools/scripts/bump-revision.sh
@@ -59,7 +59,7 @@ do
# 1, bail out and complain.
# The proper fix is to do a stricter check that PORTREVISION
# is an integer.
- awk -F "\t" '/^PORTREVISION\??=/{ rplc = gsub ($2,$2+1); if (rplc != 1) { exit 1 } };{ print }' "$1/Makefile" > $tempfile \
+ awk -F "\t+" '/^PORTREVISION\??=/{ rplc = gsub ($2,$2+1); if (rplc != 1) { exit 1 } };{ print }' "$1/Makefile" > $tempfile \
&& { cat $tempfile > "$1/Makefile" ; printc "$1: $revision found, bumping it by 1." "green" ; } \
|| printc "$1: FAILED TO BUMP PORTREVISION" red
;;