aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/jovie/Makefile
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
committeravilla <avilla@FreeBSD.org>2011-10-17 08:03:42 +0800
commit18f8d6818a2205ed543432ae7b736e36bb0b1ab5 (patch)
treea38d8a80d7330fafe33e6504e265797c7db5c8ee /accessibility/jovie/Makefile
parent7e1a35526ca99e8f9cc466c562f4184911eb911c (diff)
downloadfreebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.gz
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.tar.zst
freebsd-ports-gnome-18f8d6818a2205ed543432ae7b736e36bb0b1ab5.zip
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Diffstat (limited to 'accessibility/jovie/Makefile')
-rw-r--r--accessibility/jovie/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/accessibility/jovie/Makefile b/accessibility/jovie/Makefile
index 7fa89420c38b..cd6b20bb33a5 100644
--- a/accessibility/jovie/Makefile
+++ b/accessibility/jovie/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= ktts
+PORTNAME= jovie
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= accessibility kde
MASTER_SITES= ${MASTER_SITE_KDE}
@@ -14,31 +14,26 @@ DISTNAME= kdeaccessibility-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE text-to-speech subsystem
+COMMENT= KDE text-to-speech system
LIB_DEPENDS= speechd.5:${PORTSDIR}/accessibility/speech-dispatcher
+CONFLICTS= ktts-4.[4-6].*
+
+DISTINFO_FILE= ${PORTSDIR}/accessibility/kdeaccessibility4/distinfo
USE_BZIP2= yes
USE_CMAKE= yes
-USE_KDE4= kdeprefix kdelibs automoc4
+USE_KDE4= kdehier kdeprefix kdelibs automoc4
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build uic_build rcc_build
-USE_LDCONFIG= yes
-DISTINFO_FILE= ${PORTSDIR}/accessibility/kdeaccessibility4/distinfo
-MAKE_JOBS_SAFE= yes
-
+QT_COMPONENTS= xml qmake_build moc_build uic_build rcc_build
CMAKE_ARGS+= -DBUILD_kmousetool:BOOL=OFF
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
-BUILD_WRKSRC= ${WRKSRC}/jovie
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-post-patch:
- ${REINPLACE_CMD} -e 's|speechd|$$$\{SPEECHD_LIBRARY}|g' \
- ${PATCH_WRKSRC}/jovie/kcmkttsmgr/CMakeLists.txt \
- ${PATCH_WRKSRC}/jovie/jovie/CMakeLists.txt
-
post-install:
- cd ${WRKSRC}/doc/jovie && ${MAKE} install
${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>