aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/ark
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-02-23 03:03:17 +0800
committertcberner <tcberner@FreeBSD.org>2018-02-23 03:03:17 +0800
commitac5d54d2ae0d4bdb1d91507a4de47bc726e1c019 (patch)
tree3aad51132f546ad79059b32784badc3f6a42c8ff /archivers/ark
parentc5cfcc04963e6321cc90d144cb3bc9adbff4cf0f (diff)
downloadfreebsd-ports-gnome-ac5d54d2ae0d4bdb1d91507a4de47bc726e1c019.tar.gz
freebsd-ports-gnome-ac5d54d2ae0d4bdb1d91507a4de47bc726e1c019.tar.zst
freebsd-ports-gnome-ac5d54d2ae0d4bdb1d91507a4de47bc726e1c019.zip
Give the KDE SC4 applications ports a -kde4 suffix
In order to make room for the up-to-date version of the KDE Desktop and its applications move the KDE Application ports based on Qt4. PR: 225992 Exp-run by: antoine Reviewed by: rakuco, adridg Differential Revision: https://reviews.freebsd.org/D14413
Diffstat (limited to 'archivers/ark')
-rw-r--r--archivers/ark/Makefile36
-rw-r--r--archivers/ark/distinfo2
-rw-r--r--archivers/ark/files/patch-git_cd8ad2771
-rw-r--r--archivers/ark/pkg-descr11
-rw-r--r--archivers/ark/pkg-plist46
5 files changed, 0 insertions, 166 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
deleted file mode 100644
index 17a006e2cb4f..000000000000
--- a/archivers/ark/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# Created by: Martin Wilke <miwi@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= ark
-PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
-CATEGORIES= archivers kde kde-kde4
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Archiving tool for KDE
-
-LIB_DEPENDS= libqjson.so:devel/qjson
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-USES= cmake:outsource kde:4 libarchive cpe tar:xz
-USE_KDE= automoc4 kdelibs libkonq
-CPE_VENDOR= kde
-USE_QT4= qtestlib qmake_build moc_build rcc_build uic_build
-USE_LDCONFIG= yes
-
-OPTIONS_DEFINE= 7ZIP RAR ZIP
-
-7ZIP_DESC= Support for 7-Zip archives
-7ZIP_RUN_DEPENDS= 7z:archivers/p7zip
-
-RAR_DESC= Support for RAR archives
-RAR_RUN_DEPENDS= unrar:archivers/unrar \
- rar:archivers/rar
-
-ZIP_DESC= Support for ZIP archives
-ZIP_RUN_DEPENDS= unzip>0:archivers/unzip \
- zip:archivers/zip
-
-.include <bsd.port.mk>
diff --git a/archivers/ark/distinfo b/archivers/ark/distinfo
deleted file mode 100644
index 3d60ee0469f2..000000000000
--- a/archivers/ark/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (KDE/4.14.3/ark-4.14.3.tar.xz) = cb2ef7ea9bbfccf3b16a1242681b33c1e6c17a7458f50f0703e87678a249b8dc
-SIZE (KDE/4.14.3/ark-4.14.3.tar.xz) = 236116
diff --git a/archivers/ark/files/patch-git_cd8ad27 b/archivers/ark/files/patch-git_cd8ad27
deleted file mode 100644
index 058d208c0c68..000000000000
--- a/archivers/ark/files/patch-git_cd8ad27
+++ /dev/null
@@ -1,71 +0,0 @@
-commit cd8ad2761d41d1ec0a18cff7f4d166b53c899fc2
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Mon Nov 24 01:37:06 2014 +0200
-
- Stop crashing on exit when being used solely as a KPart.
-
- This change fixes a crash introduced by commit 3b981ca ("Remove Part
- from KXMLGUIFactory on exit").
-
- Part::~Part() is the wrong place to call KXMLGUIFactory::removeClient(),
- as it assumes addClient() had been called in the first place.
-
- This is only true if Ark is called as a standalone program, since that
- is done in MainWindow::loadPart()'s call to KXMLGuiWindow::createGUI().
-
- Conversely, if the Ark KPart is being used as an embedded viewer in,
- say, Konqueror or to preview an archive inside an archive (ie. Ark
- inside Ark) that does not hold true and we try to access a
- KXMLGUIFactory that does not exist.
-
- Instead, call KXMLGuiWindow::removeClient() in MainWindow's destructor,
- since in this case we are certain that addClient() was been called
- before.
-
- CCBUG: 341187
-
- (cherry picked from commit 9c30f30b38c36a31e6fcb3aa047a0247ac5a22fb)
- This was committed for completeness, as there will be no additional
- releases from the KDE/4.14 branch.
-
- Conflicts:
- part/part.cpp
-
---- app/mainwindow.cpp.orig 2014-10-25 12:53:24 UTC
-+++ app/mainwindow.cpp
-@@ -38,6 +38,7 @@
- #include <KDebug>
- #include <KEditToolBar>
- #include <KShortcutsDialog>
-+#include <KXMLGUIFactory>
-
- #include <QDragEnterEvent>
- #include <QDragMoveEvent>
-@@ -69,6 +70,8 @@ MainWindow::~MainWindow()
- if (m_recentFilesAction) {
- m_recentFilesAction->saveEntries(KGlobal::config()->group("Recent Files"));
- }
-+
-+ guiFactory()->removeClient(m_part);
- delete m_part;
- m_part = 0;
- }
---- part/part.cpp.orig 2014-10-25 12:53:24 UTC
-+++ part/part.cpp
-@@ -53,7 +53,6 @@
- #include <KStandardGuiItem>
- #include <KTempDir>
- #include <KToggleAction>
--#include <KXMLGUIFactory>
-
- #include <QAction>
- #include <QCursor>
-@@ -138,8 +137,6 @@ Part::Part(QWidget *parentWidget, QObjec
-
- Part::~Part()
- {
-- factory()->removeClient(this);
--
- saveSplitterSizes();
-
- m_extractFilesAction->menu()->deleteLater();
diff --git a/archivers/ark/pkg-descr b/archivers/ark/pkg-descr
deleted file mode 100644
index dfdfed20b0d5..000000000000
--- a/archivers/ark/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-Ark is a program for managing various archive formats within the KDE
-environment.
-
-Archives can be viewed, extracted, created and modified from within
-Ark. The program can handle various formats such as tar, gzip, bzip2,
-zip, rar and lha (if appropriate command-line programs are
-installed). Ark can work closely with Konqueror in the KDE
-environment to handle archives, if you install the Konqueror
-Integration plugin available in the kdeaddons package.
-
-WWW: https://utils.kde.org/
diff --git a/archivers/ark/pkg-plist b/archivers/ark/pkg-plist
deleted file mode 100644
index b80e5edb27c8..000000000000
--- a/archivers/ark/pkg-plist
+++ /dev/null
@@ -1,46 +0,0 @@
-bin/ark
-lib/kde4/arkpart.so
-lib/kde4/kerfuffle_cli7z.so
-lib/kde4/kerfuffle_clilha.so
-lib/kde4/kerfuffle_clirar.so
-lib/kde4/kerfuffle_clizip.so
-lib/kde4/kerfuffle_libarchive.so
-lib/kde4/kerfuffle_libbz2.so
-lib/kde4/kerfuffle_libgz.so
-lib/kde4/kerfuffle_libxz.so
-lib/kde4/libextracthere.so
-lib/libkerfuffle.so
-lib/libkerfuffle.so.4
-lib/libkerfuffle.so.%%KDE4_GENERIC_LIB_VERSION%%
-man/man1/ark.1.gz
-share/appdata/ark.appdata.xml
-share/applications/kde4/ark.desktop
-share/apps/ark/ark_part.rc
-share/apps/ark/arkui.rc
-share/config.kcfg/ark.kcfg
-share/doc/HTML/en/ark/ark-mainwindow.png
-share/doc/HTML/en/ark/common
-share/doc/HTML/en/ark/index.cache.bz2
-share/doc/HTML/en/ark/index.docbook
-share/doc/HTML/en/ark/man-ark.1.docbook
-share/icons/hicolor/128x128/apps/ark.png
-share/icons/hicolor/16x16/apps/ark.png
-share/icons/hicolor/22x22/apps/ark.png
-share/icons/hicolor/32x32/apps/ark.png
-share/icons/hicolor/48x48/apps/ark.png
-share/icons/hicolor/64x64/apps/ark.png
-share/icons/hicolor/scalable/apps/ark.svgz
-share/kde4/services/ServiceMenus/ark_addtoservicemenu.desktop
-share/kde4/services/ServiceMenus/ark_servicemenu.desktop
-share/kde4/services/ark_dndextract.desktop
-share/kde4/services/ark_part.desktop
-share/kde4/services/kerfuffle_cli7z.desktop
-share/kde4/services/kerfuffle_clilha.desktop
-share/kde4/services/kerfuffle_clirar.desktop
-share/kde4/services/kerfuffle_clizip.desktop
-share/kde4/services/kerfuffle_libarchive.desktop
-share/kde4/services/kerfuffle_libarchive_readonly.desktop
-share/kde4/services/kerfuffle_libbz2.desktop
-share/kde4/services/kerfuffle_libgz.desktop
-share/kde4/services/kerfuffle_libxz.desktop
-share/kde4/servicetypes/kerfufflePlugin.desktop