aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/bzip/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1996-09-27 19:47:06 +0800
committerandreas <andreas@FreeBSD.org>1996-09-27 19:47:06 +0800
commitfd43d1af7060043b16d5ac0e9215e1880944c864 (patch)
tree7fa6e8782698b8eff4a8e3699da512604b264698 /archivers/bzip/Makefile
parentf3d226e81c14e461234c36e613c65e5215a5dfd8 (diff)
downloadfreebsd-ports-gnome-fd43d1af7060043b16d5ac0e9215e1880944c864.tar.gz
freebsd-ports-gnome-fd43d1af7060043b16d5ac0e9215e1880944c864.tar.zst
freebsd-ports-gnome-fd43d1af7060043b16d5ac0e9215e1880944c864.zip
imported new port of bpatch 0.21, a compression program, that seems to have
some advantages over gzip concerning compression and memory consumption.
Diffstat (limited to 'archivers/bzip/Makefile')
-rw-r--r--archivers/bzip/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/archivers/bzip/Makefile b/archivers/bzip/Makefile
new file mode 100644
index 000000000000..1c3b801dcd99
--- /dev/null
+++ b/archivers/bzip/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bzip
+# Version required: 0.21
+# Date created: Fr 27 Sep 1996 11:47:35 MET DST
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $Id:$
+#
+
+DISTNAME= bzip-0.21
+CATEGORIES+= archivers
+MASTER_SITES= http://www.cs.man.ac.uk/arch/people/j-seward/
+
+MAINTAINER= Andreas Klemm <andreas@klemm.gtn.com>
+
+pre-install:
+ @cat ${FILESDIR}/COPYRIGHT
+
+do-install:
+ rm -f ${PREFIX}/bin/bzip ${PREFIX}/bin/bzip
+ ${INSTALL} -C -s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
+ ${WRKSRC}/bzip ${PREFIX}/bin/bzip
+ ln ${PREFIX}/bin/bzip ${PREFIX}/bin/bunzip
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
+ ${WRKSRC}/bzip.1 ${PREFIX}/man/man1/bzip.1
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
+ ${WRKSRC}/bzip.1 ${PREFIX}/man/man1/bunzip.1
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/bzip.1
+ gzip -9nf ${PREFIX}/man/man1/bunzip.1
+.endif
+
+.include <bsd.port.mk>