aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/p5-Archive-Zip
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-10-30 10:01:48 +0800
committeralane <alane@FreeBSD.org>2002-10-30 10:01:48 +0800
commit4b658b97803e7a7174ae93c1c6be6dc0f10ec8fd (patch)
tree5c8483c48cc5accc3e24a842ed43205d656db7ba /archivers/p5-Archive-Zip
parent4be92fba3bfb2b705350fcbd3066f854fa8c4235 (diff)
downloadfreebsd-ports-gnome-4b658b97803e7a7174ae93c1c6be6dc0f10ec8fd.tar.gz
freebsd-ports-gnome-4b658b97803e7a7174ae93c1c6be6dc0f10ec8fd.tar.zst
freebsd-ports-gnome-4b658b97803e7a7174ae93c1c6be6dc0f10ec8fd.zip
Use File::Spec port only for perl < 5.8.
Approved by: maintainer
Diffstat (limited to 'archivers/p5-Archive-Zip')
-rw-r--r--archivers/p5-Archive-Zip/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/archivers/p5-Archive-Zip/Makefile b/archivers/p5-Archive-Zip/Makefile
index 4f6fce1df8fe..44d31ee16e97 100644
--- a/archivers/p5-Archive-Zip/Makefile
+++ b/archivers/p5-Archive-Zip/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -23,4 +22,15 @@ PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Archive::Zip.3 Archive::Zip::Tree.3 Archive::Zip::FAQ.3 Archive::Zip::MemberRead.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_MAJOR=${PERL_VER:C|^([1-9]+).*|\1|}
+PERL_MINOR=${PERL_VER:C|^[1-9]+\.0*([1-9]+).*|\1|}
+
+.if ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif # ${PERL_MAJOR} < 5 || ${PERL_MAJOR} == 5 && ${PERL_MINOR} < 8
+
+.include <bsd.port.post.mk>